Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a problem with an end-user who can't connect to their MySQL Server.

The facts:

  • Client is Windows XP on a corporate Domain. Group policy has disabled Windows Firewall and there is no other firewalling software installed.
  • The software MySQL's own query browser, v1.1.20, and is a permitted install.
  • The username and password are correct.
  • The query browser takes longer than a normal connect when trying then returns the error message "MySQL Error Number 2003 - Can't connect to MySQL Server on 'hostname' (10060)"
  • The query browser can "ping" the server with no problem.
  • Manually connecting using Window's own telnet command succeeds and the handshake initiation is clearly visible. So the hostname resolves on that PC and there is no networking issue (e.g. routing).
  • We've tried re-installing the query browser to no avail.
  • The server is running fine and everyone else who needs to connect (including myself) can successfully connect, most of them using the exact same version. So it is not a server problem.

Googling the error shows this is a classic unavailable connection problem and lots of links show fixes for the server, but the problem seems to reside entirely in the install of the query browser, which doesn't make any sense. Thus Google is no help.

Has anyone else seen this or can offer suggestions?

share|improve this question

This may not be applicable to the OP, as their client is running on a windows XP corporate domain, but I had similar issues under OSX/Unix, encountering 2003 errors when the SSH tunnel was clearly configured correctly. Turned out it was an idiosyncrasy of the MySQL Query Browser:

Note that in *nix OSs (including Mac OS X) you must use rather than ‘localhost’ or the connection will be made via a named pipe rather than TCP. Source

I'd always thought they were completely synonymous. Once I'd made the adjustment all worked as expected - hope this helps someone.

share|improve this answer

I can't answer your question but can say I have had the same experience once before an a Win XP machine. In that instance it Query Browser wouldn't connect to MySQL server on any machine, including a local instance. As a result, I now use a third party product called MySQL-Front. It's not free, but for me at least it was well worth the price.

share|improve this answer
That's depressing. It sounds like a re-install of XP is the only solution. I don't think I can arrange that. :-( – staticsan Aug 31 '09 at 22:59
Rather than reinstall XP why not try some of the alternatives to Query Browser? After all, QB is not all that fantastic. – John Gardeniers Sep 1 '09 at 1:37
QB is a) gratis b) what everyone else here is using. Changing it means I have to support it. – staticsan Sep 6 '09 at 23:23

I may have found a solution to this problem. When connecting to the MySQL server, do not save the credentials and information in MySQL Query Browser. Instead, retype them each time when signing in. This works for me for every computer in the domain.

share|improve this answer
Interesting. Without another solution, we coded our own SQL module in the Admin code so people don't have to wrestle with the Query Browser. – staticsan May 30 '12 at 2:08

There can be so many reasons why this problem occurs, so I'll try to contribute with a few suggested solutions based on the information you provided. Remember that these suggestions are shots in the dark, since there is absolutely no way to diagnostic this problem without having access to the server. With that said I'll start listing:

  • Check that the line skip_networking is not set to ON in the config file. If it is try to comment out this line.

  • You could also check that bind-address = is not set in the config file. This line prevents everyone except localhost to connect to the database and you don't want that.

  • A third suggestion is that you could try to connect with a local account instead of a domain account. Windows Server don't allow domain accounts to use port 3306.

  • Check that the user has the privileges required to connect to the server from an external ip-address. You could try the following (or something similar):

GRANT ALL ON database.* TO username@'client ip address' IDENTIFIED BY 'password';

Remember to restart the mysql daemon each time you alter the configuration file. This error message is a little misleading, so I this helps you!

share|improve this answer
You didn't read the question. There is nothing wrong with the server it is functioning entirely correctly for all other users which I clearly said. The problem lies solely with the Query Browser on one PC. All your suggestions are for fixing the server. – staticsan Aug 31 '09 at 2:07

If you use Windows XP, then go to network adapter properties, uninstall "Microsoft TCP/IP version 6", restart your computer.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.