Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

In my job I usually have to connect to several different servers with remote desktop. However, more often than not I will get the message "Terminal server has exceeded the maximum number of allowed connections", because my colleagues just closes the remote desktop window instead of logging out.

Usually I will call the admin and get him to release one of the idle sessions on the server but this method is getting real old, real fast. So I was wondering how I setup the server so that idle sessions will timeout after 5 minutes.

share|improve this question
add comment

2 Answers

up vote 5 down vote accepted

In Terminal Services Configuration -> Connections

Right click on RDP-Tcp, choose properties and select Sessions tab.

You will then see the options for ending disconnected or idle sessions after x minutes, hours or days.

share|improve this answer
    
+1 - That's how we had our servers setup so after 30 minutes of being disconnected it would logoff the session since I was the guy that had to kick people off. –  Hondalex Aug 28 '09 at 15:24
add comment

Also configurable through group policy, if you don't feel like touching all your servers' settings individually.

share|improve this answer
2  
Computer Configuration\Administrative Templates\Windows Components\Terminal Services\Sessions\ –  Justin Love Aug 28 '09 at 14:34
    
Thanks, Justin, for being not-lazy, which I have utterly failed to do today. ;) –  Kara Marfia Aug 28 '09 at 15:28
    
Thanks Kara, thats a really good tip. ;) –  JohannesH Aug 31 '09 at 1:44
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.