Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm trying to install latest version of mysql server. I tried to uninstall mysql 4.1 using rpm -e .

Once uninstallation done I tried to download mysql packages:

Command :


but it is throwing " temporary failed name resolution "

Can anybody help me to install mysql through command-line in linux server?


/etc/resolv.conf file

   nameserver 18X.3x.86.XX // added now
   nameserver 2XX.232.2.XX
share|improve this question

1 Answer 1

That's what the problem was with your attempt to uninstall mysql with yum remove. Your system isn't on the network, or isn't fully configured for the network. Start with getting network connectivity working such that you can do dig and get a valid response (example below), then you should be able to use the wget command normally.

Example dig output:

$ dig

; <<>> DiG 9.8.1 <<>>
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 24890
;; flags: qr rd ra; QUERY: 1, ANSWER: 6, AUTHORITY: 4, ADDITIONAL: 0

;                        IN      A

;; ANSWER SECTION:         136     IN      A         136     IN      A         136     IN      A         136     IN      A         136     IN      A         136     IN      A

;; AUTHORITY SECTION:             69743   IN      NS             69743   IN      NS             69743   IN      NS             69743   IN      NS

;; Query time: 5 msec
;; WHEN: Tue May 27 14:20:30 2014
;; MSG SIZE  rcvd: 200
share|improve this answer are right. if I access using dig @<ip address> ill get the response. So what will be the wget command? – stefun May 27 '14 at 18:29
You have to get the local nameserver configuration correct. The wget command you have is correct, it's not working because you have name resolution problems. Fix the nameservers in /etc/resolv.conf. – John May 27 '14 at 18:42
I have added ip address in /etc/resolv.conf file .Now I can dig But now both yum and wget command giving timeout error – stefun May 27 '14 at 19:20
Then you have some sort of firewall issue going on. But ultimately your problem is networking, not the commands you're trying to use. – John May 27 '14 at 19:22
iptables -L -n doesn't show any firwall – stefun May 27 '14 at 19:57

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.