Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

In the Header file of the final mail on y local server using postfix i am not able to see the Sender's ip which is usually under received from.

From root@testmailer.com  Wed May 28 12:26:54 2014
Return-Path: <root@testmailer.com>
X-Original-To: kharekartik@testmailer.com
Delivered-To: kharekartik@testmailer.com
Received: by testmailer.com (Postfix, from userid 0)
        id A503876209C; Wed, 28 May 2014 12:26:54 +0530 (IST)
Subject: test
To: <kharekartik@testmailer.com>
Cc: <kharekartik@virtualmailer.com>
X-Mailer: mail (GNU Mailutils 2.2)
Message-Id: <20140528065654.A503876209C@testmailer.com>
Date: Wed, 28 May 2014 12:26:54 +0530 (IST)
From: root@testmailer.com (root)

here's the configuration of mailing server:

myorigin = $myhostname

smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

readme_directory = no

# TLS parameters
smtpd_tls_cert_file=/etc/ssl/certs/ssl-cert-snakeoil.pem
smtpd_tls_key_file=/etc/ssl/private/ssl-cert-snakeoil.key
smtpd_use_tls=yes
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache

# See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
# information on enabling SSL in the smtp client.

myhostname = testmailer.com
virtual_alias_maps = hash:/etc/postfix/virtual
alias_database = hash:/etc/aliases
#myorigin = /etc/mailname
mydestination = tcmailer8.in, karan-desktop, localhost.localdomain, localhost
relayhost =
mynetworks =192.168.1.13 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
home_mailbox = Maildir/

#sender dependent ip
sender_dependent_default_transport_maps = hash:/etc/postfix/dependent
#smtp_bind_address = 192.168.1.13

#virtual mailbox setup
virtual_mailbox_domains = /etc/postfix/vhosts
virtual_mailbox_base = /home/vmail
virtual_mailbox_maps = hash:/etc/postfix/vmaps
virtual_minimum_uid = 1000
virtual_uid_maps = static:5000
virtual_gid_maps = static:5000
share|improve this question
    
Do you have header_checks enabled? Show config of your sending server. –  edvinas.me May 28 at 7:12
    
See the edit... and thanks for replying –  user220912 May 28 at 7:16
1  
When email was delivered LOCALLY, it doesn't print any IP address because there are no smtp transaction –  masegaloeh May 28 at 8:34

1 Answer 1

When email was submitted by mail command (or sendmail binary) and delivered LOCALLY, it doesn't print any IP address because there are no smtp transaction. Here's the email flow

Pickup -> Qmgr -> smtp (relay via local)

Proof from maillog

Oct 12 08:09:51 web postfix/pickup[48333]: 865E134781F: uid=1010 from=<masegaloeh>
Oct 12 08:09:51 web postfix/cleanup[48757]: 865E134781F: message-id=<20141012010951.865E134781F@example.com>
Oct 12 08:09:51 web postfix/qmgr[79683]: 865E134781F: from=<masegaloeh@example.com>, size=327, nrcpt=1 (queue active)
Oct 12 08:09:51 web postfix/smtp[48759]: 865E134781F: to=<root@example.com>, relay=local, delay=0.21, delays=0.01/0.17/0/0.03, dsn=2.0.0, status=sent (delivered to mailbox)

As you can see, there are no TCP connection at all. Postfix just passing email between its minion programs.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.