Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to install ZeroMQ on my Debian server.

As per the instructions, I've installed libzmq-dev with aptitude, and now I'm trying to install the PHP bindings. Here I managed to install pecl, and installed zmq-beta. I edited my /etc/php5/apache2/php.ini config to include the extension.

After restarting Apache, my phpinfo() shows that ZMQ is enabled.

In one of my projects, I use composer to pull in some PHP packages, one of which called React. However I'm given the error message:

react/zmq v0.2.0 requires ext-zmq * -> the requested PHP extension zmq is missing from your system.

My extension_dir is pointing to /usr/lib/php5/20100525 from my php info, I'm not sure if this is correct.

Anyone got any clues?

share|improve this question

1 Answer 1

Turns out that I ran php -m and the extension wasn't there. Running php -i shows the config being loaded from /etc/php5/apache2/cli/php.ini. Updated that and it worked.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.