Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to install FreeNAS on a Dell PowerEdge T320. I've followed the instructions here (http://doc.freenas.org/index.php/Burning_an_IMG_File) to write the .img file to four different USB sticks with dd if=FreeNAS-9.2.1.5-RELEASE-x64.img of=/dev/sde, but I can't boot off of any of them. When I try to boot, I get the following screen:

F1 FreeBSD
F2 FreeBSD
F3 Drive 0

Then it auto-selects F1 and either prints # about once a second forever, or it sits with a blinking cursor doing nothing.

Forum posts and the wiki page linked above say to set the USB boot emulation mode to hard disk (as opposed to auto or CD/DVD/floppy), and older Dell PowerEdge models including the T310 have this option in the BIOS settings, but I cannot find it on the T320 with the latest BIOS 2.1.2.

I have even tried writing the USB image to a USB hard disk, but with the same lack of success.

Has anyone been able to find this USB boot setting on a T320, or been able to boot FreeNAS/FreeBSD from USB in some other way on a T320?

share|improve this question

2 Answers 2

I have used booting Linux from USB on the PowerEdge R320 (1RU rackmount, yours is a Tower) machines and it works fine. My machines were bought around March 2011. It sounds like it's still a BIOS issue.

One thing you may want to do is to disable the SATA and other disk related settings in the bios. From memory I recall the device not being recognised if disks were set to auto detect. Then disconnect any data connectors to other disks to make sure the O/S is only seeing the USB drive.

share|improve this answer
    
I don't think that's the issue since the BIOS does see the USB drive (else it wouldn't say FreeBSD in the boot menu). And even if this allowed me to boot, it's not a viable solution as I am trying to use the USB stick as the permanent boot device, so I need to be able to actually mount my hard disks after booting from USB. –  Icydog May 30 at 5:51
    
In older bioses (sorry, I don't have the R310 next to me at the moment) there was an option to set usb to Legacy mode. I'm sure you've experimented with all the options but sometimes it's listed under a not-so-obvious setting. Here is a report of a similar situation: forums.freenas.org/index.php?threads/… –  captcha May 30 at 6:06
    
I've gone through all the menus probably ten times by now :( I'm hoping someone will point out some very non-obvious magic incantation for this particular machine to get that option to show up. –  Icydog May 30 at 6:07

I too have been trying to install free nas but on a Dell R720 server and have exactly the same problem with it not booting from the usb stick. I have managed to install it to a internal Hdd via a free nas live CD. Free nas doesn't recommend this as you lose storage hard drive space.

share|improve this answer
    
I'm trying to avoid installing the OS on a hard disk for the same reason. –  Icydog Jun 1 at 8:28
    
This does not really answer the question. If you have a different question, you can ask it by clicking Ask Question. You can also add a bounty to draw more attention to this question once you have enough reputation. –  kasperd Jun 1 at 10:09
    
@kasperd Actually it does answer the question, it proposes not using USB but using a LiveCD instead. This counts as 'some other way'. –  sysadmin1138 Jun 1 at 12:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.