Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

When I try to turn a XP machine into a virtual machine, I am getting the Unable to Find the system Volume, reconfiguration is not impossible.

Anyone know how I work around this? The log is below.

#5] [task-1] [2009-08-28 08:55:27.444 04828 info 'App'] Using temp dir C:\WINDOWS\TEMP\vmware-temp\vmware-SYSTEM\sysReconfig

[#5] [task-1] [2009-08-28 08:55:27.444 04828 verbose 'task-1'] d:/build/ob/bora-161434/bora/sysimage/lib/converter/reconfig/reconfigurationTransaction.cpp:103

[#5] [task-1] [2009-08-28 08:55:29.819 04828 warning 'App'] [,0] Error 3 (error loading hive: The system cannot find the path specified (3)) loading temporary hive \\.\vstor2-mntapi10-1623AB41007E00000000000003000000\\Boot\BCD under key name mntApi350474103630025694.

[#5] [task-1] [2009-08-28 08:55:29.819 04828 warning 'App'] [,0] Unable to load registry hive \\.\vstor2-mntapi10-1623AB41007E00000000000003000000\\Boot\BCD, error 0x3.

[#5] [task-1] [2009-08-28 08:55:29.881 04828 warning 'App'] [,0] Error reading boot.ini file \\.\vstor2-mntapi10-1623AB41007E00000000000003000000\\boot.ini

[#5] [task-1] [2009-08-28 08:55:29.897 04828 info 'App'] [,0] boot.ini:

[#5] [task-1] [boot loader]

[#5] [task-1] timeout=30

[#5] [task-1] default=multi(0)disk(0)rdisk(0)partition(2)\WINDOWS

[#5] [task-1] [operating systems]

[#5] [task-1] multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect

[#5] [task-1] [2009-08-28 08:55:29.944 04828 error 'task-1'] Can't reconfigure a source that does not have system volume

[#5] [task-1] [2009-08-28 08:55:29.944 04828 info 'App'] Cleaning up temp directory C:\WINDOWS\TEMP\vmware-temp\vmware-SYSTEM\sysReconfig ...

[#5] [task-1] [2009-08-28 08:55:29.944 04828 error 'task-1'] TaskImpl has failed with MethodFault::Exception: converter.fault.ReconfigurationNoSystemVolumeFault

[#5] [task-1] [2009-08-28 08:55:37.022 04828 verbose 'PropertyProvider'] RecordOp ADD: event[7], task-1

[#5] [task-1] [2009-08-28 08:55:37.022 04828 info 'task-1'] ConvertTask updates, state: 4, percentage: 95, xfer rate (Bps): 782312

[#5] [task-1] [2009-08-28 08:55:37.022 04828 verbose 'PropertyProvider'] RecordOp ASSIGN: info, task-1

[#5] [task-1] [2009-08-28 08:55:37.022 04828 error 'App'] Task failed: 

[#5] [task-1] [2009-08-28 08:55:37.022 04828 verbose 'task-1'] Converter Task SetError(taskID=task-1)

[#5] [task-1] [2009-08-28 08:55:37.022 04828 verbose 'task-1'] Completing task task-1 with state=3

[#5] [task-1] [2009-08-28 08:55:37.022 04828 verbose 'App'] Converter TaskManager TaskCompleted 

[#5] [task-1] [2009-08-28 08:55:37.022 04828 info 'App'] Task Completed : task-1

[#5] [task-1] [2009-08-28 08:55:37.022 04828 verbose 'PropertyProvider'] RecordOp ASSIGN: info, task-1
share|improve this question

5 Answers 5

up vote 1 down vote accepted

I think I have a record for the number of attempts to fix this error. Each of the issues I am listing caused error messages in the log or some other symptom, but I do not know if they were fatal or not, because I never fixed the problem, but managed to work around it.

  1. Installing the recovery console on hard drive has an entry starting C:\cmdcons\ in the boot.ini file - which the system conversion routines cannot parse and trigger an error.

  2. The problem of ide vs scsi also possibly applies in my case to a SATA drive that had the OS, while another PATA drive was added to ide0 later. I just removed the drive and tried again.

  3. the system had Linux as well as XP, with partition 1 (primary) having msdos, and XP boot files. Primary partitions 2 and 3 had linux filesystems, while partition 4 was extended and had XP system as well as a few others. When I imported XP as a guest OS I explicitly removed the Linux partitions and ntfs filesystems with only data. But the converter knew that, so I presume it could cope.

  4. the other somewhat unusual setup, was that my temp partition (D:) was located in the extended partition table after the system partition (E:). I can't remember how that originally happened.

  5. my final effort was to create the VM and untick the option to reconfigure it at the end. This made a system that was not bootable, but at least the XP CD recovery boot console could see it, but not repair. By using a Linux boot CD, I was able to edit c:\boot.ini and create entries for every possible partition number. Eventually I found the right partition number, booted and reconfigured XP's concept of the partition drive letters back the way they had been.

So, in the end I do not know what really caused the problems, but I finally have a working VM.

share|improve this answer

Are there SCSI and IDE drives in the system? from this site, it says, "Converter is unable to recognize the system volume if it resides on a SCSI disk and if IDE disks are present in the source machine On source machines with SCSI and IDE disks, Converter is unable to detect the system volume if the system volume resides on a SCSI disk. Converter only checks the first IDE disk in such configurations."

share|improve this answer

I know this is an old thread, but I had the same problem. Trying to convert a physical XP Pro SP2 machine that previously had a Windows 7 installation on it. W7 had left a hidden folder behind called 'Boot' which was causing the problem. I could not delete it; even by booting from a utility CD and trying to delete. I used subinacl to reset the Boot folder permissions. Deleted the folder and also the bootmgr file (again used subinacl to alter the permissions). Check out Aaron Stebners article which describes how to obtain and use subinacl at this link: http://blogs.msdn.com/b/astebner/archive/2006/09/04/739820.aspx

Even though I had deleted the W7 partition and used XP CD recovery console (fixmbr and fixboot) to rewrite the XP boot sector and boot.ini, W7 still caused a problem.

share|improve this answer

I had the same issue on a Vista conversion. The box had multiple (x3) physical disks. Each time I ran the converter it would fail at 94%-95%.

I checked in Windows disk management and found that the active, system and boot partition, I.e. the partition I was trying to convert (PtV) was marked as physical "Disk 1", with a drive that was added to the system later (data drive), marked as physical "Disk 0".

My solution was to disable the physical "disk 0" in device manager and then reboot. Once rebooted, Windows updated the physical drive assignments I.e. "drive 1" became "drive 0", the partition identifiers stayed the same.

Once this had completed, I ran converter again, and the conversion completed successfully.

Hope this helps...

share|improve this answer

What helped me is disabling "generic volumes" - the slots for external memories enter image description here

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.