Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've been trying to host ownCloud on my server but everytime I try to it tells me this :

Your web server is not yet properly setup to allow files synchronization because the WebDAV interface seems to be broken.

Please double check the installation guides.

This is my setup :

Windows Server 2012 R2
IIS 8.5
PHP 5.5.11
ownCloud 6.0.3
MySQL 5.6.17

I tried google the error but I can't seem to find anything usefull.

Some say I should try if this works : https://cloud.mcsoftworks.net/remote.php/webdav/ and yes I can navigate to this folder and I can open files from there.

The calendar works and I can also just upload files from here https://cloud.mcsoftworks.net/ the only thing that doesn't seem to work is the sync client.

The sync client doesn't say anything it just doesn't connect (Screenshot : http://prntscr.com/3p2apz)

This is the error log :

Warning     core    isWebDAVWorking: NO - Reason: [CURL] Error while making request: Could not resolve host: cloud.mcsoftworks.net (error code: 6) (Sabre_DAV_Exception)    2014-06-02T19:56:00+00:00
Warning     core    isWebDAVWorking: NO - Reason: [CURL] Error while making request: Could not resolve host: cloud.mcsoftworks.net (error code: 6) (Sabre_DAV_Exception)    2014-06-02T19:55:47+00:00
Warning     core    isWebDAVWorking: NO - Reason: [CURL] Error while making request: Could not resolve host: cloud.mcsoftworks.net (error code: 6) (Sabre_DAV_Exception)    2014-06-02T19:55:34+00:00
Warning core    isWebDAVWorking: NO - Reason: [CURL] Error while making request: Could not resolve host: cloud.mcsoftworks.net (error code: 6) (Sabre_DAV_Exception)    2014-06-02T19:55:34+00:00
Fatal   webdav  Sabre_DAV_Exception_Forbidden: Path does not exist, or escaping from the base path was detected 2014-06-02T19:54:37+00:00
Fatal   webdav  Sabre_DAV_Exception_Forbidden: Path does not exist, or escaping from the base path was detected 2014-06-02T19:54:36+00:00
Fatal   webdav  Sabre_DAV_Exception_Forbidden: Path does not exist, or escaping from the base path was detected 2014-06-02T19:54:36+00:00
Fatal   webdav  Sabre_DAV_Exception_Forbidden: Path does not exist, or escaping from the base path was detected 2014-06-02T19:54:36+00:00
Warning core    isWebDAVWorking: NO - Reason: [CURL] Error while making request: Could not resolve host: cloud.mcsoftworks.net (error code: 6) (Sabre_DAV_Exception)    2014-06-02T19:51:24+00:00

This is my php.ini : http://pastebin.com/es3MB8Uh

Does anyone have any idea on how I should get this to work? I've been trying to get this to work for about 14 days now and it starts to annoy me =P

UPDATE :

Okay so today I installed the newest version of the client on my PC and this client returned an error I think the other client just didn't show this error but the error is :

Error downloading [hostname]/remote.php/webdav/- server replied : Method Not Allowed

http://prntscr.com/3p9dx1

LOG FILE UPDATE:

Fatal   webdav  Sabre_DAV_Exception_Forbidden: Path does not exist, or escaping from the base path was detected 2014-06-03T13:40:17+00:00
Fatal   webdav  Sabre_DAV_Exception_Forbidden: Path does not exist, or escaping from the base path was detected 2014-06-03T13:40:17+00:00
Fatal   webdav  Sabre_DAV_Exception_Forbidden: Path does not exist, or escaping from the base path was detected 2014-06-03T13:40:16+00:00
Fatal   webdav  Sabre_DAV_Exception_Forbidden: Path does not exist, or escaping from the base path was detected 2014-06-03T13:40:15+00:00
Fatal   webdav  Sabre_DAV_Exception_Forbidden: Path does not exist, or escaping from the base path was detected 2014-06-03T13:39:28+00:00
Fatal   webdav  Sabre_DAV_Exception_Forbidden: Path does not exist, or escaping from the base path was detected 2014-06-03T13:39:24+00:00
Fatal   webdav  Sabre_DAV_Exception_Forbidden: Path does not exist, or escaping from the base path was detected 2014-06-03T13:30:32+00:00
Fatal   webdav  Sabre_DAV_Exception_Forbidden: Path does not exist, or escaping from the base path was detected 2014-06-03T13:30:31+00:00
Fatal   webdav  Sabre_DAV_Exception_Forbidden: Path does not exist, or escaping from the base path was detected 2014-06-03T13:30:31+00:00
Warning core    isWebDAVWorking: NO - Reason: [CURL] Error while making request: Could not resolve host: cloud.mcsoftworks.net (error code: 6) (Sabre_DAV_Exception)    2014-06-02T20:09:05+00:00
Error   PHP Undefined index: accessclass at D:\Websites\MCS-oCloud\apps\calendar\lib\object.php#889 2014-06-02T20:02:16+00:00
Warning core    isWebDAVWorking: NO - Reason: [CURL] Error while making request: Could not resolve host: cloud.mcsoftworks.net (error code: 6) (Sabre_DAV_Exception)    2014-06-02T19:56:07+00:00
Warning core    isWebDAVWorking: NO - Reason: [CURL] Error while making request: Could not resolve host: cloud.mcsoftworks.net (error code: 6) (Sabre_DAV_Exception)    2014-06-02T19:56:00+00:00
Warning core    isWebDAVWorking: NO - Reason: [CURL] Error while making request: Could not resolve host: cloud.mcsoftworks.net (error code: 6) (Sabre_DAV_Exception)    2014-06-02T19:55:47+00:00
share|improve this question
    
Don't forget to check the handlers for WebDAV and delete it, I still had problems until I did that. –  Keith Jul 16 at 8:12
add comment

2 Answers 2

The most likely reason for this error is that your server cannot communicate with itself. This could be because your router does not have NAT reflection so your server cannot communicate with itself on its public IP. Try adding a cloud.mcsoftworks.net pointing to 127.0.0.1 in your hosts file (or your internal DNS if you have) so that the server knows to contact itself instead of going out on the Internet.

Alternatively, this could be because your server is not allowing the WebDAV HTTP Verbs through to PHP. See the OwnCloud setup guide for instructions on making sure these settings are set up properly.


As discussed in the OwnCloud forum, the OwnCloud sync client also does not necessarily work with self-signed certificates. Try switching to HTTP temporarily and see if that works. (However, others have gotten self-signed certififcates to work with no problem, and the error you are receiving does not say that this is the issue despite the fact that the symptoms are the same.)

You may also just be having an issue where WebDAV is working properly but the tests are failing, thus preventing WebDAV from working. You can bypass the WebDAV tests in the admin site by adding check_for_working_webdav=false to the config.php file.

share|improve this answer
    
Okay I just added cloud.mcsoftworks.net to my hosts file and the server is now rebooting. I already changed the HTTP Verb to all quite some days ago. I will comment if it worked soon. –  Nobleleader13245 Jun 2 at 20:39
    
:( It didn't work I also tried without SSL and this also didn't work. Just before I changed it to http it did came up with an error 405 method not allowed. –  Nobleleader13245 Jun 2 at 20:59
    
@Nobleleader13245 the only way I know of to get a 405 is if the verbs are set wrong. –  Moshe Katz Jun 2 at 21:02
    
I did enable these verbs this is what I did : prntscr.com/3p320c –  Nobleleader13245 Jun 2 at 21:06
    
@Moshe_Katz It still doesn't seem to work :( –  Nobleleader13245 Jun 3 at 13:03
add comment
up vote 0 down vote accepted

Okay, I found out what the problem was. in the IIS 8.5 manager there is a tab called modules if you open that it displays tons of modules search for WebDavModule and delete it.

@Moshe_Katz Thanks for the help.. it pointed me in the right direction.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.