Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm new with Apache Cassandra. I am trying to install a little sample cluster using two CentOS server. I followed the documentation (Tarball installation) and the nodes are up. However, when I go to OpsCenter, the nodes cannot see each other's agent (there is always "1 of 2 agents connected"..I tried to fix, but nothing change).

I tried both to disable and enable SSL, I tried to set the incoming_interface in opscenter.conf, I tried almost everything the network suggested to me, but the problem persisted.

Is there someone that could help me, please?

share|improve this question

2 Answers 2

up vote 1 down vote accepted

I don't know much about your configuration, but experienced a similar use case myself, where the opscenter only had data from the local datastax agent.

My initial setup was: 3 cassandra nodes, all 3 running opscenter and datastax-agent, with the agent configured for the local node. It seems that this was wrong, as the agents needed to be configured with (one?) opscenter address. I decided to only run the agents in all 3 nodes, but opscenter only in one of them, and configured all 3 agents to point to that node (agent/bin/setup ... this updates conf/address.yaml). This fixed my problem. I still don't know how to setup opsCenter to more than one host, but that's a different problem.

share|improve this answer
    
Oh, thank you, thank you, thank you! You have solved my mistery! For the first time I see "All agents connected"...great return from holiday! Now, I try to think of a solution about this new problem. –  Alice Aug 29 at 13:31

I would recommend reviewing /var/lib/datastax-agent/conf/address.yaml on the nodes to validate that they both contain the hostname or ip address of the machine that is running opscenter in the "stomp_interface" setting.

Also, sometimes it is useful when initially configuring a cluster to restart both the agents and opscenter, and then to reload opscenter in your browser.

share|improve this answer
    
I tried all of these solutions, but nothing changed... –  Alice Jun 26 at 15:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.