Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've got a folder on a Windows 2003 R2 machine. I uncheck the "read-only" checkbox option, tell it to apply to all subfolders, and click ok.

it appears to work, except when I check it again, the read-only checkbox remains checked.

I'm logged in as administrator, and I verified that I'm the owner of that folder and its contents.

What am I missing?

share|improve this question
    
Probably duplicate. Have a look at this question. serverfault.com/questions/53187/… –  squillman Aug 29 '09 at 0:00

5 Answers 5

up vote 7 down vote accepted

This bug has been around since Win95 was released. i.e. The checkbox is checked regardless of the actual state of the attributes. Just ignore it.

share|improve this answer

Are there hidden files or folders in the folder? If so that could cause the check box to become rechecked.

share|improve this answer
    
I've had this happen to me as well. It is well worth checking out. –  Craig Feb 9 '10 at 17:14

You can also use the attrib command to ensure the properties are set.

attrib /?

  • to set properties, - to remove properties.
share|improve this answer

Removing the Read-Only attribute via the DOS command proved to resolve my NFS permissions issue. (ie: attrib -r ) Thus, do NOT ignore the shaded Windows GUI checkbox that the folder is flagged Read-Only. "Windows" may not care, but Unix/AIX does!

share|improve this answer

I had this issues and found it was related to the share permissions of the root directory, it was set to everyone read and therefore people could only read regardless of whether they had permission in the sub folders.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.