Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Mysql (including InnoDB) was working fine, after a restart the other day when mysql starts it says in the logs:

140604 23:36:07 [Note] Plugin 'FEDERATED' is disabled.
140604 23:36:07 [Note] Plugin 'InnoDB' is disabled.

In the app it says:

SQLSTATE[42000]: Syntax error or access violation: 1286 Unknown storage engine 'InnoDB'

Now, according to google this is a very simple fix, just remove the ib_logfile[0|1] files, which I have done and does not do anything.

I started by making a full copy of the data dir for testing various 'fixes'.

I have also uninstalled mysql and reinstalled it with no change, I just cant get it to run with innodb working anymore :/

# mysql --version
mysql  Ver 14.14 Distrib 5.5.37, for debian-linux-gnu (x86_64) using readline 6.3

I have also tried the innodb_force_recovery setting, 0 -> 6, Any time I run a command on an InnoDB table it says innodb_force_recovery

LOGS (from around the time it died)

was working here
Version: '5.5.37-0ubuntu0.14.04.1'  socket: '/var/run/mysqld/mysqld.sock'  port: 3306  (Ubuntu)
140530  1:24:22 [Note] /usr/sbin/mysqld: Normal shutdown

140530  1:24:22 [Note] Event Scheduler: Purging the queue. 0 events
140530  1:24:22  InnoDB: Starting shutdown...
140530  1:24:24  InnoDB: Shutdown completed; log sequence number 3345857316
140530  1:24:24 [Note] /usr/sbin/mysqld: Shutdown complete

140530 22:03:12 [Warning] Using unique option prefix myisam-recover instead of myisam-recover-options is deprecated and will be removed in a future release. Please use the full name instead.
140530 22:03:12 [Note] Plugin 'FEDERATED' is disabled.
140530 22:03:12 InnoDB: The InnoDB memory heap is disabled
140530 22:03:12 InnoDB: Mutexes and rw_locks use GCC atomic builtins
140530 22:03:12 InnoDB: Compressed tables use zlib 1.2.8
140530 22:03:12 InnoDB: Using Linux native AIO
140530 22:03:12 InnoDB: Initializing buffer pool, size = 128.0M
140530 22:03:12 InnoDB: Completed initialization of buffer pool
140530 22:03:12 InnoDB: highest supported file format is Barracuda.
140530 22:03:15  InnoDB: Waiting for the background threads to start
140530 22:03:16 InnoDB: 5.5.37 started; log sequence number 3345857316
140530 22:03:16 [Note] Server hostname (bind-address): '192.168.1.20'; port: 3306
140530 22:03:16 [Note]   - '192.168.1.20' resolves to '192.168.1.20';
140530 22:03:16 [Note] Server socket created on IP: '192.168.1.20'.
140530 22:03:16 [Note] Event Scheduler: Loaded 0 events
140530 22:03:16 [Note] /usr/sbin/mysqld: ready for connections.

140602  0:58:39 [Note] Event Scheduler: Purging the queue. 0 events
140602  0:58:39  InnoDB: Starting shutdown...
140602  0:58:41  InnoDB: Shutdown completed; log sequence number 3345954467
140602  0:58:41 [Note] /usr/sbin/mysqld: Shutdown complete
does not work anymore
140602 21:45:19 [Warning] Using unique option prefix myisam-recover instead of myisam-recover-options is deprecated and will be removed in a future release. Please use the full name instead.
140602 21:45:19 [Note] Plugin 'FEDERATED' is disabled.
140602 21:45:19 [Note] Plugin 'InnoDB' is disabled.
140602 21:45:19 [Note] Server hostname (bind-address): '192.168.1.20'; port: 3306
140602 21:45:19 [Note]   - '192.168.1.20' resolves to '192.168.1.20';
140602 21:45:19 [Note] Server socket created on IP: '192.168.1.20'.
140602 21:45:19 [Note] Event Scheduler: Loaded 0 events
140602 21:45:19 [Note] /usr/sbin/mysqld: ready for connections.
share|improve this question
    
Show the rest of the log file entries. –  Michael Hampton Jun 4 at 22:59
    
updated with logs from where it was working to where it died –  dogmatic69 Jun 4 at 23:05
    
skip-innodb in config? –  akuzminsky Jun 4 at 23:14
    
no, innodb was working fine before and the config has not changed. –  dogmatic69 Jun 4 at 23:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.