Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am using webmin on FreeBSD 9.2, when I goto the squid panel it tells me

Your Squid cache directory /var/squid/cache/squid has not been initialized.This must be done before Squid can be run.

It gives me a button to Initialize the chache, and upon doing so I get this output:

Initializing the Squid cache with the command /usr/local/sbin/squid -f /usr/local/etc/squid/squid.conf -z .. 2014/06/05 01:27:59| Creating Swap Directories

Upon returning to the squid panel, I still see the same message about my cache directory not being initialized. I have made sure the permissions are set and the owner are set to squid user.

Can someone offer me a little guidance here ? I have looked at the similar questions that have been ask, but did not find any that were of any help.

share|improve this question
    
Never mind, I actually had to add the path in the .conf file, just letting it use the default path without setting it doesn't allow it to work correctly. My issues has been solved, thank you for your time. –  James Jun 5 at 6:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.