Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I've installed passenger as ruby gem. I've added following to /etc/apache2/apache2.conf

LoadModule passenger_module /var/lib/gems/1.8/gems/passenger-2.2.4/ext/apache2/mod_passenger.so
PassengerRuby /usr/bin/ruby
PassengerRoot /var/lib/gems/1.8/gems/passenger-2.2.4

and set Vitual Host to rails app ~/public directory, but when I visit the site, I only see content of dispatch.fcgi, but nothing gets executed

.htaccess in ~/public directory is

AddHandler fcgid-script .fcgi
AddHandler cgi-script .cgi
Options +FollowSymLinks +ExecCGI

RewriteEngine On
RewriteRule ^$ index.html [QSA]
RewriteRule ^([^.]+)$ $1.html [QSA]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule ^(.*)$ dispatch.fcgi [QSA,L]

However, if I run script/server, everything works fine, so there is no problem with the application itself.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Passenger doesn't execute Rails requests via dispatch.fcgi. Have you tried following the Passenger installation instructions?

share|improve this answer
    
yep, I even ran through modrails.com/documentation/Users%20guide%20Apache.html two timeson different machines, once with gem and once with ubuntu package, but neither did help –  Jakub Arnold Aug 29 '09 at 7:24
    
Nothing in that documentation mentions dispatch.fcgi. –  womble Aug 29 '09 at 11:14
    
dispatch is generated when you do rails xx -D, thats because I migrated project from other other server, where it was necessary, anyway, problem solved by rebooting whole server (apache reboot didn't suffice) –  Jakub Arnold Aug 30 '09 at 12:08
    
Rails generates a lot of things, but that doesn't mean you have to use them. –  womble Aug 30 '09 at 22:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.