Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to add multiple PHP version in Plesk 12. Switching my domain to the new version PHP 5.4.29 result in this error:

(104)Connection reset by peer: mod_fcgid: error reading data from FastCGI server

Here is phpinfo() of the complied PHP version, obtained running php54-cgi index.php from the terminal. The same script placed under document root doesn't work in FastCGI.

How can I debug/try to figure out what's the error?

Currently running CentOS 6.5 x64, Plesk v12.0.18_build1200140529.2, PHP 5.5.13. I've downloaded PHP 5.4.29:

cd /usr/local/src
curl -O http://it1.php.net/distributions/php-5.4.29.tar.gz
cd php-5.4.29

And configured with:

./configure \
--prefix=/usr/local/php54 \
--with-bz2 \
--with-config-file-path=/usr/local/php54/etc \
--with-config-file-scan-dir=/usr/local/php54/etc/php.d \
--with-curl \
--with-gd \
--with-gettext \
--with-iconv \
--with-layout=PHP \
--with-libxml-dir=/usr/local/php54 \
--with-mhash \
--with-mysql=mysqlnd \
--with-mysqli=mysqlnd \
--with-openssl \
--with-pdo-mysql=mysqlnd \
--with-readline \
--with-xsl \
--with-zlib \
--enable-calendar \
--enable-cgi \
--enable-exif \
--enable-ftp \
--enable-intl \
--enable-mbstring \
--enable-pcntl \
--enable-shmop \
--enable-sockets \
--enable-sockets \
--enable-sysvmsg \
--enable-sysvsem \
--enable-sysvshm \
--enable-wddx \
--enable-zip

Then:

make && make install
Installing PHP CLI binary:        /usr/local/php54/bin/
Installing PHP CLI man page:      /usr/local/php54/php/man/man1/
Installing PHP CGI binary:        /usr/local/php54/bin/
Installing PHP CGI man page:      /usr/local/php54/php/man/man1/
Installing build environment:     /usr/local/php54/lib/php/build/
Installing header files:          /usr/local/php54/include/php/
Installing helper programs:       /usr/local/php54/bin/
  program: phpize
  program: php-config
Installing man pages:             /usr/local/php54/php/man/man1/
  page: phpize.1
  page: php-config.1
Installing PEAR environment:      /usr/local/php54/lib/php/
[PEAR] Archive_Tar    - installed: 1.3.11
[PEAR] Console_Getopt - installed: 1.3.1
warning: pear/PEAR requires package "pear/Structures_Graph" (recommended version 1.0.4)
warning: pear/PEAR requires package "pear/XML_Util" (recommended version 1.2.1)
[PEAR] PEAR           - installed: 1.9.4
Wrote PEAR system config file at: /usr/local/php54/etc/pear.conf
You may want to add: /usr/local/php54/lib/php to your php.ini include_path
[PEAR] Structures_Graph- installed: 1.0.4
[PEAR] XML_Util       - installed: 1.2.1
/usr/local/src/php-5.4.29/build/shtool install -c ext/phar/phar.phar /usr/local/php54/bin
ln -s -f /usr/local/php54/bin/phar.phar /usr/local/php54/bin/phar
Installing PDO headers:          /usr/local/php54/include/php/ext/pdo/

Copied php.ini-production to /usr/local/php54/etc/php.ini and added a new handler in Plesk:

/usr/local/psa/bin/php_handler --add -displayname 5.4.29 -path /usr/local/php54/bin/php-cgi -phpini /usr/local/php54/etc/php.ini -type fastcgi -id php54

Symbolic linking:

ln -s /usr/local/php54/bin/php /usr/local/bin/php54
ln -s /usr/local/php54/bin/php-cgi /usr/local/bin/php54-cgi

New installed version:

php54-cgi -m

[PHP Modules]
bz2
calendar
cgi-fcgi
Core
ctype
curl
date
dom
ereg
exif
fileinfo
filter
ftp
gd
gettext
hash
iconv
intl
json
libxml
mbstring
mhash
mysql
mysqli
mysqlnd
openssl
pcntl
pcre
PDO
pdo_mysql
pdo_sqlite
Phar
posix
readline
Reflection
session
shmop
SimpleXML
sockets
SPL
sqlite3
standard
sysvmsg
sysvsem
sysvshm
tokenizer
wddx
xml
xmlreader
xmlwriter
xsl
zip
zlib

[Zend Modules]
share|improve this question

1 Answer 1

There may be several reasons for this, which is nicely described in Parallels article

http://kb.sp.parallels.com/en/120785

Also, I suggest you to re-register the php with fcgi module through command line and see if that helps.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.