Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've configured some sites on IIS pointing to E:\WebApps and subfolders. In basic settings when I click the Test Settings... button (connection as the application user) I get the error:

The server is configured to use pass-through authentication with a built-in account to access the specified physical path. However, IIS Manager cannot verify whether the built-in account has access. Make sure that the application pool identity has Read access to the physical path. If this server is joined to a domain, and the application pool identity is NetworkService or LocalSystem, verify that \$ has Read access to the physical path. Then test these settings again.

I've checked that my IIS is running as NETWORK SERVICE so I've given read, read and execute and list folders contents access to not only E:\WebApps but also to E:. But I still get the error. This machine is not part of a domain. Any ideas what am I missing?

I've tried putting a web.config in E:\WebApps, and restarting IIS and the site in particular, but it made no difference.

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

I couldn't get the verification to work (anywhere else than in my workstation computer), but in the end I moved on and everything worked just fine, so maybe it wasn't that important.

share|improve this answer
add comment

Please try: 1) Replace child folder permissions 2) web.config file is available in the folder e:\WebApps 3) Restart IIS.

share|improve this answer
    
What do you mean replace child folder permissions? And by putting a web.config, do you mean just dropping a blank one? –  J. Pablo Fernández Aug 29 '09 at 9:46
    
Yes, replace child folder NTFS permissions from Security -> Advanced option of folder permissions. Regarding placing web.config file, you need to have one with all basic website level setting in <system.webServer> tag. –  kilko Aug 30 '09 at 12:06
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.