Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am running 64 Bit SQL Server 2008 and when I am trying to access that instance from 32 Bit SQL Server Management Studio on another machine, I am getting the error :

"A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: SQL Network Interfaces, error: 26 - Error Locating Server/Instance Specified) (Microsoft SQL Server, Error: -1)"

I have ensured the following:

a. There are no firewall issues (as it is within our LAN and the required ports are open)

b. SQL Browser service is already running on both the machines

c. TCP/IP and Named pipes protocols have already been enabled on the server machine.

d. There are no network issues as I am able to ping the server machine

Am I missing anything else? Thanks in advance for guidance.

share|improve this question
    
Are you able to connect to other remote servers from the 32bit SSMS? Can you try to connect via SQLCMD -S<64bitserver>? –  SqlACID Aug 29 '09 at 13:34
    
have you tried to use the ip address and portnumber of the server, in case of a DNS related problem. –  Hakan Winther Aug 29 '09 at 13:43

3 Answers 3

  1. Check the SQL Server error log to make sure it is listening on a TCP port. If there is an error given, you'll need to restart SQL Server.
  2. On the server running SQL Server, execute from the command line netstat -ano and look for the TCP port. Make sure it has a status of listening. Compare the PID given for that port against the PID for SQL Server. They should match. If there is no match, you'll need to restart SQL Server.
  3. Check the firewall on the server running SQL Server (not a hardware firewall in between, but the Windows firewall). Ensure that the port isn't being blocked. If it is, reconfigure the firewall.
  4. Try to telnet to the server and port via telnet server port. For instance MySQLServer 9999 if 9999 is the port its listening on. If that doesn't work, engage your networking folks to do a trace. See if the TCP session is being established, etc.
  5. If all that works, try and connect via SSMS using server,port. For instance, MySQLServer,9999.
  6. If that works, try stopping and restarting the SQL Server Browser service on the SQL Server. Then try to connect with ServerName\InstanceName. I have seen cases where SQL Server is up and listening on the port and for whatever reason SQL Server Browser is not responding properly.
share|improve this answer

Here are a few more suggestions:

  • Make sure TCP/IP is also enabled on your client's SQL Native Client configuration.
  • Make sure remote connections are enabled on the server
  • Are you trying to connect to the default instance or a named instance on the server?

To configure SQL Native Client on your workstation:

  1. Open SQL Server Configuration Manager
  2. Expand SQL Native Client Configuration
  3. Click Client Protocols
  4. Enable protocols and set their order of use as appropriate

To enable remote connections on your server (via SSMS):

  1. Right-click your server instance and get properties
  2. Click on Connections in the menu
  3. Make sure the Allow remote connections to this server is checked
  4. Restart the instance
share|improve this answer

As per the solution from Brian, I have verified and found that port number 1433 is blocked by windows firewall. I have added it under exception and now connectivity is OK. The problem is resolved. Thanks for the solution.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.