Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am running Windows 7 ultimate and im trying to manage VM's on my Hyper-V server via the MMC. I can connect to the machine, but I get the "You do not have the required permissions to complete this task. Please contact..." message.

I have used the HVRemote script and ran all of the required commands on another Windows 7 machine on my network and it worked perfect, I do the same on my machine and I get the permissions error.

For now I have disabled the firewall on my machine and the server, and still nothing. Ive rebooted both machines.

How can I adjust the permissions here? Any ideas on why the other Windows 7 machine works flawless and Im getting the error?

Thanks very much,

share|improve this question

2 Answers 2

A coworker was running into this issue, and had to change a DCOM permission setting. Walkthrough is here, though the issue had nothing to do with VPN in our case, this still resolved it.

share|improve this answer

Are you 100% sure you're running the Hyper-V manager mmc with credentials that have admin access to the hyper-v server(s)? Try a "run as" by shift-right clicking on the manager icon.

share|improve this answer
    
I've tried this - run as administrator, and as my user account that has admin access and no luck –  barfoon Aug 29 '09 at 18:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.