Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I had Owncloud running on a server that had died, I remember installing being easy, I have migrated server and Owncloud is one of the last apps to install.

Ok Just downloaded and installed the newest version of Owncloud on a Ubuntu 14.04 server with PHP 5.5.9-1, I am trying the manual install. I have tried adding repo and installing from apt-get install owncloud, did not work for me :/, whereis owncloud reported nothing. It's installed but never was able to bring up site.

Now for my issue I finished the manual install from .tar.bz2 when it came time to login I receive

"This webpage has a redirect loop"

, I receive the error from Chrome and Safari web browsers. I can't login at all, with no user, I get the error page.

Don't know if it is related or not but here's a look at the owncloud-error.log

"RSA certificate configured for "mysite.com" Does NOT include an ID which matches the server name"

Installed new ssl cert with CN as my ServerName directive in the vhost config file, same error :/ Re-installed owncloud same issue... Out of ideas.

Thanks in advance, jmituzas

share|improve this question

closed as off-topic by Jacob, Falcon Momot, mdpc, kce, Tom O'Connor Jun 12 at 13:55

This question appears to be off-topic. The users who voted to close gave these specific reasons:

  • "Questions must be relevant to professional system administration. Server Fault is dedicated to professional system and network administrators. End user and enthusiast questions are off-topic (contact your system administrator or hire a professional to help you out). Please see the Help Center for more information." – mdpc, Tom O'Connor
  • "Questions must demonstrate a minimal understanding of the problem being solved. Try including attempted solutions, why they didn't work, and the expected results. See How can I ask better questions on Server Fault? for further guidance." – Jacob, Falcon Momot, kce
If this question can be reworded to fit the rules in the help center, please edit the question.

2 Answers 2

It sounds like it might be getting the server name not from the ServerName directive, but rather from the system (i.e. hostname), or from another configuration directive. Correcting the machine's hostname according to the appropriate process for your distribution might help.

If there are any other application errors in owncloud-error.log you should correct them too.

share|improve this answer

I edited the default-ssl.conf file to fit owncloud. Here is my updated file:

<IfModule mod_ssl.c> <VirtualHost _default_:52000>
ServerAdmin webmaster@localhost

DocumentRoot /var/www/owncloud

# Available loglevels: trace8, ..., trace1, debug, info, notice, warn,
# error, crit, alert, emerg.
# It is also possible to configure the loglevel for particular
# modules, e.g.
#LogLevel info ssl:warn

ErrorLog ${APACHE_LOG_DIR}/owncloud.error.log
CustomLog ${APACHE_LOG_DIR}/owncloud.access.log combined

# SSL Engine Switch:
# Enable/Disable SSL for this virtual host.
SSLEngine on

# A self-signed (snakeoil) certificate can be created by installing
# the ssl-cert package. See
# /usr/share/doc/apache2/README.Debian.gz for more info.
# If both key and certificate are stored in the same file, only the
# SSLCertificateFile directive is needed.
SSLCertificateFile /etc/apache2/ssl/owncloud.pem
SSLCertificateKeyFile /etc/apache2/ssl/owncloud.key

#SSLOptions +FakeBasicAuth +ExportCertData +StrictRequire
<FilesMatch "\.(cgi|shtml|phtml|php)$">
SSLOptions +StdEnvVars
</FilesMatch>
<Directory /usr/lib/cgi-bin>
SSLOptions +StdEnvVars
</Directory>

BrowserMatch "MSIE [2-6]" \
nokeepalive ssl-unclean-shutdown \
downgrade-1.0 force-response-1.0
# MSIE 7 and newer should be able to use keepalive
BrowserMatch "MSIE [17-9]" ssl-unclean-shutdown

# Have apache 2.4
<Directory /var/www/owncloud>
Options Indexes FollowSymLinks MultiViews
AllowOverride All
Require all granted
</Directory>

</VirtualHost>
</IfModule>

Fixed my error in cloud-error.log Ok cleared cookies, brought up owncloud login page, enter credentials click login get the error:

This webpage has a redirect loop

One error fixed now if I could log in.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.