Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've configured an additional network interface with only private address but i can't reach that server using this newly created address.

Here are the steps I've done:

  • created 2 machines: A and B (same zone).
  • created an additional ENI with a new private address
  • configured a single security group with all traffic (inbound and outbound) allowed.
  • attached the new ENI to A.
  • configured the ubuntu box to setup the new interface (eth1 auto)

From B to A using the primary private IP I can access all services, but using the new private IP address (from the new ENI), I can't.

May I missed something?

eth1 config file

auto eth1 iface eth1 inet dhcp

ifconfig eth1

eth1      Link encap:Ethernet  HWaddr 0a:c2:2a:39:ef:8f  
          inet addr:172.31.12.138  Bcast:172.31.15.255  Mask:255.255.240.0
          inet6 addr: fe80::8c2:2aff:fe39:ef8f/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:9001  Metric:1
          RX packets:983 errors:0 dropped:0 overruns:0 frame:0
          TX packets:21 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:94662 (94.6 KB)  TX bytes:3006 (3.0 KB)
share|improve this question

1 Answer 1

up vote 0 down vote accepted

You're missing the routing. By default the routing will only go to eth0. You have to route traffic that is identified as coming from eth1 to the gateway, currently all that traffic is being discarded.

I answered a similar question here, maybe it can help you solve your issue:

Second ENI in AWS VPC is not accessible on Ubuntu instance

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.