Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a Windows server, 2008 R2 running Hyper-V. I have downloaded the Windows Server 2012 RC DC version from here.

I am "forced" to install a download app that copies a .vhd file to my chosen directory.

The instructions on this page say that to install the VHD:

  • Download the VHD file.
  • Start Hyper-V Manager. On the Action menu, select Import Virtual Machine.
  • Navigate to the directory that the virtual machine file was extracted to and select the directory (not the directory where the VHD file is located).
  • Select the Copy the virtual machine option.**
  • Confirm that the import was successful by checking Hyper-V Manager.
  • Configure the network adapter for the resulting virtual machine: right-click the virtual machine and select Settings. In the left pane, click Network Adapter. In the menu that appears, select one of the network adapters of the virtualization server, and then click OK.
  • Start the virtual machine.

Where it says Navigate to the directory that the virtual machine file was extracted to and select the directory (not the directory where the VHD file is located). Select the Copy the virtual machine option, I have a problem.

Nothing has been extracted as far as I can tell, and if it has, I have no idea where or what I'm looking for.

I tried creating a new VM and using the downloaded .vhd file but I got an error saying that the .vhd file is an incompatible format.

share|improve this question

closed as off-topic by TomTom, TheCleaner, mdpc, Falcon Momot, HopelessN00b Jun 10 at 12:55

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions must demonstrate a minimal understanding of the problem being solved. Try including attempted solutions, why they didn't work, and the expected results. See How can I ask better questions on Server Fault? for further guidance." – TomTom, HopelessN00b
If this question can be reworded to fit the rules in the help center, please edit the question.

    
I think the question is possibly useful. I download the same eval vhd last week and have hit the same problem. However I am running hyper-v under 2012-r2, so it has nothing to do with the version. I haven't found a solution to the problem of how to use this vhd yet, but I think the question could be reworded a little to be a pertinent question. I have tried attaching the vhd to a new vm and importing the contents of the directory as indicated. Attaching produces a 'file version not permitted' error (translated) and importing finds nothing to import. –  Ian Murphy Jun 10 at 13:22

1 Answer 1

up vote 0 down vote accepted

You have at least two problems to solve.

1) You're trying to run a VHD intended for a recent version of Hyper-V (with a recent version of Windows Server )on top of a five year old version. It might work, but a version spread that large isn't supported.

2) You're trying to import (if you can find the extracted files) a VM created with a recent version of Hyper-V, saved in the current export format, which Server 2008 R2 won't be able to read, as it is much older. For this, you'll be better off just creating a new VM rather than importing an existing one. Point your new VM at the old VHD.

Of course, you'll probably have much greater success running this on Server 2012 R2 or Windows 8.1.

share|improve this answer
    
Thanks for reply. The page says the file is compatible though? "To use the VHD distribution, you must have a computer running Windows Server 2008 R2, Windows Server 2012, or Windows Server 2012 R2. The Hyper-V server role must be installed." . If I upgrade the physical box from 2008R2 to 2012R2 I will no doubt break the existing 2008R2 created Vm's running on there. Begs the question why MS insist on causing friction. It's 2014, I don't care about any of this. Life's too short. If the file isn't compatible then this day and age it should auto upgrade it. I just want to load and go. –  Paul Hale Jun 9 at 22:02
    
Ok just found this which pretty much explains all... sigh... support.microsoft.com/kb/2744129/en-us –  Paul Hale Jun 9 at 22:18

Not the answer you're looking for? Browse other questions tagged or ask your own question.