Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I was successfully able to install CentOS 6.5 x86_64 Minimal from CD, and setup software raid during the install steps, after having set the Dell PowerEdge 2850 to SCSI Mode which enabled CentOS to see all the drives. Everything appeared to go smoothly, like previous installs I've done on other servers (perhaps not this same make/model) and desktops.

But, after rebooting the server acted like it didn't know there was anything to boot. I checked BIOS boot priorities and the LSI boot tool and made sure things looked like they were setup to boot. During the post boot up I see the drives listed as expected.

It appears to just hang, as well, no message about failing to find a bootable device. It just hangs after the IPMI step I believe.

Any ideas why the server is acting like it can't see the OS to boot?

Thanks

share|improve this question
    
Drivers or firmware? I seem to remember having the same problem with a Dell server of that vintage, which I solved by upgrading the controller firmware from the 1.00 version which wasn't supported in CentOS to... Well, the most recent one (at the time), which worked just fine. –  HopelessN00b Jun 10 at 22:16
    
Thanks for the suggestion. I'll see if there's anything to that. –  user10330 Jun 10 at 22:23

1 Answer 1

Is it a GPT partition table? If so, you need a bios_grub aka "Reserved BIOS boot area" partition (not the same as /boot) or things don't work right, especially with software raid. Also with grub and Linux softraid, your /boot should be raid1, and ideally not metadata 1.2.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.