Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm running a website on a VPS running Centos 6.5 and am having some issues. I'm new to serveradmin so just learning. atop was already installed on our machine and it's working. I wanted to go in and analyse the historical logs but there is nothing in /var/log/atop/, the atop directory is there but is empty.

I thought that it's configured to create logs by default? The man pages are here: http://linux.die.net/man/1/atop

I changed the cron -> /etc/cron.d/atop from

0 0 * * * root /etc/rc.d/init.d/atop condrestart > /dev/null 2>&1 || :

to

0 0 * * * root /etc/atop/atop.daily

Should this get the log file working?

Any pointers would really help. I'm looking to see if my cpu usage is going crazy at a certain point or I'm running out of RAM which is why i'm using atop.

Thanks.

share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

Put /etc/cron.d/atop back to

0 0 * * * root /etc/rc.d/init.d/atop condrestart > /dev/null 2>&1 || :

Run

chkconfig atop on
service atop start
share|improve this answer
    
Thanks a lot sciurus, it's working now and the log files are being created. So atop wasn't configured to run automatically on startup and that's what chkconfig atop on did? Does it matter about these runlevels? It's on for the default 2-5 alright. –  user23744 Jun 11 at 12:02
    
Yes, it wasn't configured to run on boot and chkconfig enabled it. Yes, running on those runlevels is good. –  sciurus Jun 12 at 1:42
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.