Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I get following exception - when I run Hadoop in the Multi node (2) environment.

Master - Node - My Laptop - ubuntu 13 Kylin (116.203.210.25)

Slave Node - Ubuntu 12 VM

I follow -

http://www.quuxlabs.com/tutorials/running-hadoop-on-ubuntu-linux-multi-node-cluster/

Data Node - configuration -

conf/slaves (master only)

This conf/slaves file lists the hosts, one per line, where the Hadoop slave daemons (datanodes and tasktrackers) will be run. We want both the master box (116.203.210.25) and the slave box to act as Hadoop slaves because we want both of them to store and process data.

master slave

Now when I run the - shart-dfs.sh command,in Master(NameNode) I found both in Master and slave (Ubuntu VM) node Log file following exception in DATA Node Log file.

WARN org.apache.hadoop.hdfs.server.datanode.DataNode: org.apache.hadoop.ipc.RemoteException: java.io.IOException: ProcessReport from dead or unregisterted node: 116.203.210.25:50010

That means -

1) Ubuntu - VM box (slave) DATA Node running Fine.

2) Problem with as I guess - when master node (116.203.210.25)try to behave as Data Node as mentioned in the link.

But when I do the JPS - both node shows expected result that Data node is running.

How Can I resolve this issue.

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.