Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

what i have done:

/etc/modprobe.d/blacklist.conf

blacklist net-pf-10
blacklist ipv6

/boot/grub/menu.lst

title           Ubuntu 9.04, kernel 2.6.28-15-server
kernel          /boot/vmlinuz-2.6.28-15-server ... ro quiet splash ipv6.disable=1
initrd          /boot/initrd.img-2.6.28-15-server
quiet

But still:

root@bubi:~# ip a | grep inet6
    inet6 ::1/128 scope host
    inet6 fe80::a00:27ff:fecf:c12e/64 scope link
root@bubi:~#

Any idea?

share|improve this question
6  
Why do you want to do that? –  grawity Aug 30 '09 at 11:31
1  
the question is how to disable not why to disable but isn't is so obvious, i am not using ipv6 and really annoying to see ::1 and so in in netstat output, i want to disable it like on other unixes –  Istvan Aug 30 '09 at 11:46
5  
fix is listed as committed in ubuntu kernel, and should be coming out in the next security release. All the same, disabling ipv6 on all of your systems because you're not using it seems a head in the sand approach. You are going to have to deal with IPv6 at some point in the future. There are cases where it makes sense to disable it (the Opera case is a reasonable one). It's annoying in netstat is not one of them. –  Cian Aug 31 '09 at 3:11
1  
i am the one who is deciding what is annoying on my system, but thanks to confirm that it is a real problem because it is fixed in the next release :) –  Istvan Aug 31 '09 at 14:54

3 Answers 3

up vote 4 down vote accepted

I've read much about that, and it seems to be a bug in 9.04 distribution. You'll have to recompile the kernel without ipv6 in order to do it.

My case was that Opera does not work with ipv6 turned on.

share|improve this answer
1  
in the meantime i have found the page describing that 9.04 is broken, ipv6 cannot be disabled i feel the smell of enterprise :DD ipv6 is evil for some reason: -DNS lookups -browsers and other tools using ipv6 at first to communicate -firewall, security questions There must be a way to disable it on any operating system IMHO. –  Istvan Aug 30 '09 at 12:49
5  
IMO, that IPv6 cannot be disabled in Jaunty could be considered a feature. People have to stop thinking that IPv6 is just an optional feature that can be disabled. In fact, disabling IPv6 may make your computer unable to communicate with others on the network (newer versions of Windows and OS X, as well as Linuxes, all communicate via IPv6 by default). The problem you describe is that Opera is just broken. Fix Opera for once or use a non-broken browser. –  Juliano Aug 30 '09 at 15:30
1  
completely disagree you have no idea about security considerations and performance questions i would like to control my operating system and if i want disable ipv6 –  Istvan Aug 30 '09 at 17:54
5  
l1x: I have perfect idea about security and performance considerations. I manage static and dynamic IPv6 connections for a few companies. Security considerations of IPv6 are exactly the same as for IPv4: you have to manage your firewall properly. IPv6 itself shouldn't impact performance except perhaps because a slightly bigger header (that only happens when you transmit over IPv6). Otherwise, it is because of broken applications like Opera. Again not IPv6 fault. –  Juliano Aug 30 '09 at 18:21
1  
I see, so here is one case study for you: -i have a linux system with iptables and we are filtering the incoming and outgoing connections, but only ipv4 because we are not running any ipv6 service. we update to the next kernel and realize that somebody just attacked our service from a unfiltered ipv6 ip because we are in the same layer2 space in the co-loc company how should i deal with this issue? change my approach not to do anything with ipv6 just because somebody forced to enable it in the releasing team? i don't think that you see my point at all... –  Istvan Aug 31 '09 at 14:51

I think the best solution is to drop all IPv6 traffic via firewall.
There is manual how to use ip6tables in Linux: ip6tables: IPv6 Firewall For Linux

share|improve this answer

sysctl -w net.ipv6.conf.all.disable_ipv6=1 try this is working for me.

share|improve this answer
    
no it is not working :( –  Istvan Aug 30 '09 at 11:53
    
is that u facing slow browsing i'm also using same kernel and old kernel had that bug which i got fix by Ub12 so it has work in u r setup i'll try in other system and let u know how we can get this fix –  Rajat Aug 30 '09 at 18:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.