Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I recently deployed a php site to IIS 7.5 on Windows server 2008 r2 that works fine locally and worked fine yesterday. Today, we tried to execute the scripts on the server and it failed to access the directories(full control for IUSR & IIS_IUSRS) that it requires to execute some powershell scripts. I checked the user account that the site is being run under, pass-through authentication with anonymous authentication but, when I run a get_current_user() via php he returned name is $ rather than the application pool identity whereas on my other servers it shows the application pool identity like ASP .net 4.0

Any ideas?

UPDATE: killed the site out of IIS, cleared the directories, pushed the site back onto the server and readded it as a site. It's working for now.

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.