Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I've installed Datastax opscenter v4.1.2. It was bundled with Datastax Cassandra Community edition version 2.0.8. I'm running these on Windows Server 2008 R2 64-bit. When I open opscenter all agents are connected and all the stats are displayed except the widget for Storage capacity which shows no information.


The opescenterd.log files shows (IP address removed):

 2014-06-16 12:24:01+0100 [local] ERROR: Agent for xx.xxx.x.xx was unable to complete operation (http://xx.xxx.x.xx:61621/os-metric/disk-space?): java.io.IOException: Process failed: wmic LogicalDisk where DriveType=3 get DeviceId,Size,FreeSpace /Format:csv

  Exit val: 44210
  Output:
Invalid XSL format (or) file name.

The opscenter-agent log shows:

 ERROR [os-metrics-11] 2014-06-16 12:29:39,564 Short os-stats collector failed: Process failed: wmic LogicalDisk where DriveType=3 get DeviceId,Size,FreeSpace /Format:csv

Exit val: 44210

Output:

Invalid XSL format (or) file name.

Both messages are repeated at regular intervals. Can anyone advise on this error please?

share|improve this question
    
I've never seen the "Invalid XSL format" error before. Googling seems to suggest it's related to locale. Are you running on a non en-US version of windows? Try running the following command from cmd.exe and paste the output here: wmic LogicalDisk where DriveType=3 get DeviceId,Size,FreeSpace /Format:csv –  mbulman Jun 24 '14 at 14:40
    
Thanks for your help. It was indeed the locale which is not set here to en-US. Running the wmic command pointed to the /Format:csv causing the problem in that csv.xsl couldn't be found hence the "Invalid XSL format" (which acutally mean't file not found). As a workaround I copied en-US/csv.xsl the the system32 directory and all the metrics now work. –  user226491 Jul 3 '14 at 9:27

1 Answer 1

This is a bug in Windows 7 WMIC. When you use Dutch regional settings in an English Windows installation, WMIC searches for the xsl files inside C:\Windows\System32\wbem\nl-NL, instead of C:\Windows\System32\wbem\en-US where they are.

Workarounds:

  1. Create a folder named C:\Windows\system32\wbem\nl-NL (or whichever locale you use, check HKCU\Control Panel\International\LocaleName) and copy the C:\Windows\system32\wbem\en-US\*.xsl files into it.
  2. Change your regional settings to match your Windows language version, log out and back in.
  3. Specify the full path: WMIC process get /format:"%WINDIR%\System32\wbem\en-US\csv".
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.