Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've a Windows 2008 SBS running. It boots of iSCSI. That setup worked for months until yesterday. I intended to reboot and gained a: STOP 0x0000007b INACCESSIBLE_BOOT_DEVICE and no idea why. My setup hasn't changed. No new controller, no new or changed iSCSI targets, no new Network Card or IP address changes. I had all Windows Updates on it. Last known good: same STOP. Allow unsigned drivers: same STOP. Safe mode (all variants): same STOP. Mount target from a client: works. Filesystem check fine. I booted of the SBS DVD but in computer repair options my target doesn't appear. When i choose setup the target appears. So, how can i diagnose what's going wrong? Any helpful tools? Any hints?

Thanks in advance

Michael

share|improve this question
    
What iSCSI card are you using? Or is it built into the board? –  Mark Henderson Aug 30 '09 at 23:56
    
The network card boots gpxe via pxe. gpxe establishes the inital iSCSI connection and passes the connection information by iBFT to windows. The target is a linuxserver running iscsi software that exposes a software raid6. –  Michael Aug 31 '09 at 0:27
    
Ah. I've never done an iSCSI boot in this fashion before, sorry... –  Mark Henderson Aug 31 '09 at 1:43
add comment

4 Answers

That STOP error code usually means Windows was unable to load a proper driver for the storage controller it needs to access the OS volume, so it just gives up booting as soon as it should be relying on its own device drivers instead of BIOS.

This can happen if the boot storage controller gets changed without informing the OS, as in physically changing it with a different make/model, or configuring it to appear to the OS as something different; it's a common error if you configure a SATA controller to emulate an IDE one, install Windows using it and then change it back to full SATA mode.

Maybe something was changed in the system BIOS or iSCSI card's config?

share|improve this answer
    
You're basically right. That's the usual cause for STOP 0x7b. But the Computer has no disk and no (i)scsi controller (only floppycontroller and ide controller with one dvd drive attached). As I've answedered to Farseeker's question: the network card gets a copy of gpxe and starts that. gpxe establishes a iscsi connection to a windows 2008 sbs setup and boots it. after that, microsoft iscsi driver takes over and establish also a connection to the same iscsi target. it takes it's config info of iBFT from gpxe. I need to know what goes wrong at that switch to ms iscsi. How can I diagnose? –  Michael Aug 31 '09 at 9:52
add comment

Maybe this can help?

share|improve this answer
    
That's a great tip. But it doesn't match my problem. The MAC address of the NIC is unchanged and still the same nick as I always booted of. I'm sure because it's configured via DHCP identified by it's MAC address. –  Michael Aug 31 '09 at 16:17
add comment

Changing the slot the network adapter is in can also cause this. If you move it back, problem solved. You are supposed to run iscsibcg /fix /verify automatically on every shutdown to help reduce this problem, which can also be caused by driver updates, service packs, and random junk like that.

share|improve this answer
1  
This is true of PCI devices, but no PCIe, it doesn't work that way anymore. –  Chris S May 15 '12 at 3:20
add comment

Another possibility: Maybe the Windows server en the Linux box are unchanged, but what about the LAN in between ?

Did your network admin change anything related to 802.1q, QoS or jumbo-frames ?

If so gpxe might be able to deal with it, but the MS network-stack and/or iSCSI implementation are somewhat less-capable in my experience.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.