Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have installed Ubuntu server ("Jaunty") onto a hardware RAID 1 setup. I have now (after successful install) added 2 new drives which I'd like to also have in hardware (or software) RAID 1.

When I setup a hardware RAID array for the new drives, the next boot into Ubuntu failed miserably. During startup it hangs just after a line which says something about RAID array missing or not enough parameters.

I tried this even on another controller int he same machine, had the same problem.

Having given up on that, I tried using MDADM to create a software RAID volume, but I must have done something wrong becasue when I go: sudo cat /proc/mdstat I get a /dev/md_d0 device listed, but whe I try to remove or touch that device in anyway, I get the message 'file or device not found'.

Ignoring THAT issue, I then tried to create a new array as /dev/md0 using MDADM, but it lists one of the drives (specifically /dev/sda1) as being busy or in use - despite having blown away all partitions on the drive and creating a fresh single partition on the while drive.

In either case, something really weird seems to be going on, and my real-life linux people are no help becasue they dont have any xperience in theis area (I am a linux noob). In order to help me, to help myself, I was wondering if there was a tool for gnome I could use on the (gnome-core/x-windows I installed) to help me manage these arrays. I installed Gparted, but it doesnt seem to help me with RAIDed volumes.

What GUI RAID tools for gnome can I use to help configure this 2nd array, like a GUI version of LVM or something?

share|improve this question

1 Answer 1

up vote 0 down vote accepted

A bit web based, but you could try the tool: webmin

share|improve this answer
    
Yes it di, thank you very much for your help. I still had to screw-arround with the console, but the webmin pointed me in the right direction for sure! :) –  Ash Sep 1 '09 at 0:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.