Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've spent a few hours now without achieving any outcome trying to vagrant up a box of mine. It works perfectly on my mac and two of my coworkers mac but when trying to vagrant up that box on my windows desktop I get an error like this:

INFO runner: Running action: # C:/HashiCorp/Vagrant/embedded/gems/gems/vagrant-1.6.3/lib/vagrant/action/builtin/box_add.rb:358:in box_add': undefined methodname' for nil:NilClass (NoMethodError)

The full error log can be found here: https://gist.github.com/anonymous/f227b9fb37aae643d276#file-vagrantuperror

Hope you guys can help me, thanks!

vagrant

share|improve this question

1 Answer 1

I had the same problem and filed this issue against vagrant:

https://github.com/mitchellh/vagrant/issues/4100

It looks like the problem is due to some goofy behavior of Ruby's Pathname.join on Windows.

You should be able to solve the problem and get your box running by setting config.vm.box_url to what you have as config.vm.box, and setting config.vm.box to some name (.e.g. "ubuntu"). This worked for me.

So what you want in your Vagrantfile, based on your log, is something like

Vagrant.configure("2") do |config|
    config.vm.box = "socialplus"
    config.vm.box_url = "http://ci.synergy-gb.com/socialplus.box"
    ...
end
share|improve this answer
    
Solved my issue +1 –  Floradu88 Aug 12 at 10:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.