Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm trying to configure the DNS for my CloudFlare in my cPanel my host provided me and this keeps happening!

http://i.gyazo.com/49f1e16abf97a254168d4c1dcdeea331.png

But, the thing is that my domain is already pointed to my CloudFlare and I waited 24 hours, got an email saying it was updated fully and stuff. Now I tried hooking it up with my hosting by using the cPanel, this is what it shows every time.

share|improve this question

2 Answers 2

up vote 0 down vote accepted

You should just click the grey cloud to toggle the cloudflare. Remember you can just click the clouds to turn on or off the cloudflare for your domain. Delete your domain from cloudflare and try again via your cpanel.

share|improve this answer
    
I did that just a few minutes ago, as I realized that might be why. I deleted it and it worked succesfully. Although, it said wait 5 minutes for it to update and it still hasn't updated. –  user3646954 Jun 22 at 5:33
    
@user3646954 5 mins is approx time for DNS update. Sometimes DNS update takes longer than expected. If it still fails more than 48 hours contact your host. –  Daniel Hyuuga Jun 22 at 5:34
    
Its been about 15 minutes. And okay, I will wait longer. Just to show you, incase. This is what it looks like. i.gyazo.com/c22b359ced460a3995de66062412f1b4.png I'm not sure if theres anything wrong with it @DanielHyuuga –  user3646954 Jun 22 at 5:35
    
@user3646954 Reason why your website won't load because your website doesn't have ANY dns record. Contact your host or try see your cloudflare account and try modify the dns records as show in your cpanel advanced dns zone editor –  Daniel Hyuuga Jun 22 at 5:43
    
This is what it shows in my DNS Zone Editor. i.gyazo.com/947c0631ed61aa7be1d0b0c66978699b.png What do I do? –  user3646954 Jun 22 at 5:44

You can't activate through their panel option if you're already pointing to our nameservers (the error message is the screen shot is telling you that). If you want to switch to the panel option instead, then you need to change away from our nameservers first & then activate through the panel option.

Note: We can only provision CNAMEs when activating through a hosting partner. If you want to proxy and protect the A web traffic records, then I would recommend just keeping things as they are now (pointing to our nameservers).

share|improve this answer
    
I had mine pointed at yours, never changed anything in the DNS and after uploading some stuff to my FTP the website started to become unavailable. It was literally the exact second afterward. But a couple hours ago I could upload no problem and it didn't affect anything. It even showed up with the stuff on the website. i.gyazo.com/ca0a44a9d461758aaaa258346116ad5e.png –  user3646954 Jun 22 at 18:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.