Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am having trouble trying to install phpmyadmin. We are using AWS services for our servers. Our mysql db is located in an RDS instance. Now I am trying to install phpmyadmin on an EC2 instance.

I have installed mysql-client on the EC2 instance. When I try to install phpmyadmin, the install dialog prompts me to create a database for phpmyadmin, asking me the root user credentials.

The problem is, by default the install dialog is trying to log into the database instance at localhost, which does not exists because our db instance is on a remote RDS instance.

I can skip this step and install phpmyadmin, make the necessary configurations and login to the db instance on RDS, but can not execute queries because of the missing phpmyadmin table.

How can I get the phpmyadmin install dialog to use the db instance on RDS by default?

share|improve this question
    
What install dialog? The phpMyAdmin setup script (like you can view at demo.phpmyadmin.net/master/setup)? That's the only thing that comes to mind that you could mean and you just tell it the proper host name or IP address, so I'm not convinced that we're talking about the same thing. How are you trying to install? –  ibennetch Jun 24 at 4:45
    
@ibennetch No, I forgot to mention my OS. While installing phpmyadmin on Ubuntu 12.04 using the command "apt-get install phpmyadmin", the install dialog opens. I can not enter my hostname in that dialog, it just tries to configure phpmyadmin for localhost. This is what the dialog looks like: bala-krishna.com/webfiles/uploads/2011/01/… –  Ozgur Akcali Jun 24 at 11:43

1 Answer 1

up vote 0 down vote accepted

That dialog comes from apt-get attempting to make your configuration easy for you, but it seems to assume you're installing to a database on the local machine. In this case, you should say no to that dialog; you'll have to manually configure the "phpMyAdmin Configuration Storage". Even though the dialog says you "must" have the database installed, I don't think that's true. It's certainly not true with the official release; it works perfectly fine without configuring those advanced features.

Once you install phpMyAdmin through apt-get, you'll need to edit the configuration file to point to the RDS database hostname or IP address. I'm pretty sure you'll find the configuration in /etc/phpmyadmin/.

Once you've gotten phpMyAdmin installed, you can use the documentation in /usr/share/doc/phpmyadmin to create the database manually (you'll most likely log in through phpMyAdmin and upload the file), but again, I don't think that's needed at all.

What I would do, however, is just download the source from http://www.phpmyadmin.net/ and uncompress it yourself in to your web root folder (which is likely /var/www/) and configure it manually. That way you're not confusing apt-get.

Hope this helps get you on your way.

share|improve this answer
    
Thanks, I had handled the configuration, but had problems creating the default database. Then I found out that there is a .sql file within the phpmyadmin installation (sth. like create_tables.sql) to create the initial database and gone with that. –  Ozgur Akcali Jun 24 at 13:38
    
By the way, without installing the default database, I couldn't run queries on phpmyadmin, getting error messages about missing configuration tables. It is possible to go without installing the database, but then you should remove the configuration options pointing to those tables. –  Ozgur Akcali Jun 24 at 13:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.