Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm running opsview (nagios) and 1 slave server doesn't execute some plugins correctly

Return code of 127 is out of bounds - plugin may be missing

when I execute the plugin manually it says

./check_icmp
bash: ./check_icmp: No such file or directory

on the master and other slaves it's working when executing the plugins

I have been googling and trying stuff for days now but can't get it working

edit:solved by Kyle Brandt (see comments)

share|improve this question

1 Answer 1

up vote 1 down vote accepted

My first guess would be that the file doesn't have executable permissions. What user are you running it as? If the file is owned by the user or a group the user is in, if there are no executable permissions for the user, then even if 'all' has executable permissions, the user still won't be able to run it.

So for instance, if it is owned by the user Nagios, but there the file doesn't have executable permission for user, then you will get that error, even if file is executable by all / others:

[kbrandt@kbrandt-opadmin: ~/scrap] ls -l true.pl                                                                                                <24252@6:17>
-rw-rw-r-x 1 kbrandt kbrandt 603 2009-04-14 13:17 true.pl
[kbrandt@kbrandt-opadmin: ~/scrap] ./true.pl                                                                                                   
zsh: permission denied: ./true.pl

The same goes for groups. If a file were owned by the user 'Joe' and the group 'Nagios', and user kbrandt who is a member of group Nagios tried to run it, if the group column doesn't have executable permission, kbrandt won't be able to run it.


Update after long Comment Thread:
Have you tried Recompiling the plug-ins on that machine?

thats it! the files get copied from another (intel machine) automatically by opsview on this one! compiling plugins from source worked

share|improve this answer
    
ls -alh|grep icmp: -r-sr-x--x 1 root nagios 32K 2009-08-24 15:28 check_icmp running chmod 777 won't work either also used chmod +s etc. whatever I do it wont run –  hoberion Aug 31 '09 at 11:23
    
You have setuid set on it, is the filesystem mounted with nosuid option? The mount command will show you the mount options. –  Kyle Brandt Aug 31 '09 at 11:24
1  
also it would not generate the error message "No such file or directory" but "permission denied" –  hoberion Aug 31 '09 at 11:25
    
"is the filesystem mounted with nosuid option?" (rw,relatime) –  hoberion Aug 31 '09 at 11:28
1  
Looks right if it is a 32 bit system, have you tried recompiling the plugins on that machine? –  Kyle Brandt Aug 31 '09 at 11:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.