Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm having some sort of an IIS config issue. Using IE, I can open HTML files, but cannot open ASPX pages.

I have tried running "aspnet_regiis.exe -i", but it did not correct the issue.

Web extensions show "ASP.NET 1.1.4322" and "ASP.NET 2.0.50727" as both set to "Allowed".

Any ideas?

share|improve this question
    
is it that the browser displays them as blank pages or do they pop up and you are given the option to save the file locally? –  Keith Aug 31 '09 at 18:45
    
Is there a MIME type set for ASPX? (Shouldn't be.) –  Michael Todd Aug 31 '09 at 19:14
    
You don't mention how you are trying to "open" them.... through a browser? Is ASP.NET registered with IIS? See msdn.microsoft.com/en-us/library/k6h9cz8h%28VS.80%29.aspx –  Ash Machine Aug 31 '09 at 20:18

2 Answers 2

Based on the solution you listed, it would make sense that your script mappings were screwy.

To check: (in IIS manager)

  1. Right click on the web site/application and hit "Properties".
  2. Click the "Home Directory" tab.
  3. Click "Configuration" on the bottom half of the tab.
  4. Under the "Mappings" tab, make sure that all of the proper file extensions are mapped to the framework ISAPI dll.

You would need to consult a healthy machine for a complete list of extensions.

share|improve this answer
    
You can also run aspnet_regiis.exe -i. msdn.microsoft.com/en-us/library/k6h9cz8h(VS.80).aspx Let's you easily switch isapi bindings to a specific version of asp.net. –  Jarrod Dixon Sep 17 '09 at 3:26
up vote -2 down vote accepted

I figured it out... sort of. The solution (if you want to call it that) was to uninstall IIS, reinstall IIS, then reinstall Windows 2003 Server SP2. After that, works perfectly.

share|improve this answer
    
I would have tried running <.net framework directory>\aspnet_regiis.exe -i first - it sounded like your isapi bindings were messed up. –  Jarrod Dixon Sep 17 '09 at 3:23
    
I did try that. It made no difference. –  scottmarlowe Sep 18 '09 at 14:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.