Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm getting this error while installing ajenti.

yum install ajenti
    Error: Missing Dependency: python-chardet is needed by package reconfigure-0.1.50-1.noarch (ajenti)

Any idea?

share|improve this question

1 Answer 1

I got the same error and found the solution. It seems happens because EPEL repo is not properly added on your system.

  1. First, check the version of your operating system (CentOS 6.x/5.x? 32-bit/64-bit):

    cat /etc/*-release

  2. Next, add the repo using these few lines:

    CentOS 5.x:

    wget http://dl.fedoraproject.org/pub/epel/5/x86_64/epel-release-5-4.noarch.rpm
    wget http://rpms.famillecollet.com/enterprise/remi-release-5.rpm
    sudo rpm -Uvh remi-release-5*.rpm epel-release-5*.rpm
    

    CentOS 6.x:

    wget http://dl.fedoraproject.org/pub/epel/6/x86_64/epel-release-6-8.noarch.rpm
    wget http://rpms.famillecollet.com/enterprise/remi-release-6.rpm
    sudo rpm -Uvh remi-release-6*.rpm epel-release-6*.rpm
    
  3. Now enable remi:

    vim /etc/yum.repos.d/remi.repo
    

    In [remi] change enable=0 to enable=1.

  4. Now type command yum install ajenti and it should succeed.

For more detail see here.

share|improve this answer
    
I have followed same steps. It works only on Centos 6 not working in Centos 5. –  Abraham Van Helsing Jun 28 at 7:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.