Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I receive the following error when attempting to start apache through the init.d script:

*apache2: Syntax error on line 186 of /etc/apache2/apache2.conf: Syntax error on line 4 of /etc/apache2/mods-enabled/auth_sm.conf: Cannot load /apps/netegrity/webagent/bin/ into server: cannot open shared object file: No such file or directory*

SiteMinder does not officially support Ubuntu, so I am having trouble finding any configuration documentation to help me troubleshoot this issue.

I successfully installed the SiteMinder binaries and registered the trusted host with the server, but I am having trouble getting the apache mod to load correctly.

I have added the following lines to a new auth_sm.conf file in /etc/apache2/mods-available and symlinked to it in /etc/apache2/mods-enabled:

SetEnv LD_LIBRARY_PATH /apps/netegrity/webagent/bin

LoadModule sm_module /apps/netegrity/webagent/bin/
SmInitFile "/etc/apache2/WebAgent.conf"

Alias /siteminderagent/pwcgi/ "/apps/netegrity/webagent/pw/"

<Directory "/apps/netegrity/webagent/pw/">
   Options Indexes MultiViews ExecCGI
   AllowOverride None
   Order allow,deny
   Allow from all

UPDATE: Output of ldd

    ldd /apps/netegrity/webagent/bin/ =>  (0xb8075000) => /apps/netegrity/webagent/bin/ (0xb7ec0000) => /apps/netegrity/webagent/bin/ (0xb7ebb000) => /lib/tls/i686/cmov/ (0xb7e9a000) => /lib/tls/i686/cmov/ (0xb7e96000) => /lib/tls/i686/cmov/ (0xb7e8d000) => /usr/lib/ (0xb7dd3000) => /lib/tls/i686/cmov/ (0xb7dad000) => /lib/ (0xb7d9e000) => /lib/tls/i686/cmov/ (0xb7c3a000) => /apps/netegrity/webagent/bin/ (0xb7c37000)
        /lib/ (0xb8076000)


The easiest way to set environment variables for the Apache run user in Ubuntu is to edit the /etc/apache2/envvars file and add export statements for any library paths you may need

share|improve this question

2 Answers 2

up vote 1 down vote accepted

It looks like libmod_sm22 is trying to load a linked library and isn't finding it where it expects. Try:

ldd /apps/netegrity/webagent/bin/

and see if you can move the library it is looking for to the path it expects it to be in.

share|improve this answer
I gave that a shot and it looks like everything is loading. I updated the question with the output from ldd. – Matt Franklin Aug 31 '09 at 17:31
Just realized I didn't run ldd as root. As root some of the dependencies were not found. I am going to fix the path issue. Thanks. – Matt Franklin Aug 31 '09 at 17:43

worked for me after adding following entry in envvars

export PATH
share|improve this answer
Siteminder installation/configuration for Oracle HTTP Server on Redhat Linux worked by adding the env variables to instance opmn.xml file. This file is located in $ORACLE_INSTANCE/config/OPMN/opmn/ folder. – user205924 Jan 17 '14 at 19:47

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.