Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

My os is OSX.When I do ssh localhost, always ask password to me.But I don't know password.How to login without password.

    ➜  ~  rm -rf ~/.ssh 
    ➜  ~  ssh-keygen
    ➜  ~  ls -lstra ~/.ssh 
    total 16
    8 -rw-r--r--   1 abc  staff   418 Jun 28 19:58 id_rsa.pub
    8 -rw-------   1 abc  staff  1679 Jun 28 19:58 id_rsa
    0 drwx------   4 abc  staff   136 Jun 28 19:58 .
    0 drwxr-xr-x+ 63 abc  staff  2142 Jun 28 19:58 ..
    ➜  ~  ssh localhost
The authenticity of host 'localhost (127.0.0.1)' can't be established.
RSA key fingerprint is 09:80:bd:41:32:39:a4:ed:c4:b6:89:f8:8c:b7:94:9e.
Are you sure you want to continue connecting (yes/no)? yes
Warning: Permanently added 'localhost' (RSA) to the list of known hosts.
Password:

My ssh debug output.

➜  .ssh  ssh -v localhost 
    OpenSSH_5.9p1, OpenSSL 0.9.8y 5 Feb 2013
    debug1: Reading configuration data /etc/ssh_config
    debug1: /etc/ssh_config line 20: Applying options for *
    debug1: Connecting to localhost [127.0.0.1] port 22.
    debug1: Connection established.
    debug1: identity file /Users/abc/.ssh/id_rsa type 1
    debug1: identity file /Users/abc/.ssh/id_rsa-cert type -1
    debug1: identity file /Users/abc/.ssh/id_dsa type -1
    debug1: identity file /Users/abc/.ssh/id_dsa-cert type -1
    debug1: Remote protocol version 2.0, remote software version OpenSSH_5.9
    debug1: match: OpenSSH_5.9 pat OpenSSH*
    debug1: Enabling compatibility mode for protocol 2.0
    debug1: Local version string SSH-2.0-OpenSSH_5.9
    debug1: SSH2_MSG_KEXINIT sent
    debug1: SSH2_MSG_KEXINIT received
    debug1: kex: server->client aes128-ctr hmac-md5 none
    debug1: kex: client->server aes128-ctr hmac-md5 none
    debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
    debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
    debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
    debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
    debug1: Server host key: RSA 09:80:bd:41:32:39:a4:ed:c4:b6:89:f8:8c:b7:94:9e
    debug1: Host 'localhost' is known and matches the RSA host key.
    debug1: Found key in /Users/abc/.ssh/known_hosts:1
    debug1: ssh_rsa_verify: signature correct
    debug1: SSH2_MSG_NEWKEYS sent
    debug1: expecting SSH2_MSG_NEWKEYS
    debug1: SSH2_MSG_NEWKEYS received
    debug1: Roaming not allowed by server
    debug1: SSH2_MSG_SERVICE_REQUEST sent
    debug1: SSH2_MSG_SERVICE_ACCEPT received
    debug1: Authentications that can continue: publickey,keyboard-interactive
    debug1: Next authentication method: publickey
    debug1: Offering RSA public key: /Users/abc/.ssh/id_rsa
    debug1: Authentications that can continue: publickey,keyboard-interactive
    debug1: Offering RSA public key: /Users/abc/.ssh/id_rsa
    debug1: Authentications that can continue: publickey,keyboard-interactive
    debug1: Offering RSA public key: /Users/abc/.ssh/id_rsa
    debug1: Authentications that can continue: publickey,keyboard-interactive
    debug1: Offering RSA public key: /Users/abc/.ssh/id_rsa
    debug1: Authentications that can continue: publickey,keyboard-interactive
    debug1: Trying private key: /Users/abc/.ssh/id_dsa
    debug1: Next authentication method: keyboard-interactive
    Password:
share|improve this question

closed as off-topic by Iain, HBruijn, dawud, EEAA, Falcon Momot Jun 28 at 19:13

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions must be relevant to professional system administration. Server Fault is dedicated to professional system and network administrators. End user and enthusiast questions are off-topic (contact your system administrator or hire a professional to help you out). Please see the Help Center for more information." – dawud, EEAA, Falcon Momot
If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer 1

You have to add your key (content of id_rsa.pub) to ~/.ssh/authorized_keys

share|improve this answer
    
@deagh thanks, but not work.Where am I doing wrong.? ➜ .ssh cat id_rsa.pub >> authorized_keys ➜ .ssh ll total 32 -rw-r--r-- 1 abc staff 418B Jun 28 20:11 authorized_keys -rw------- 1 abc staff 1.6K Jun 28 19:58 id_rsa -rw-r--r-- 1 abc staff 418B Jun 28 19:58 id_rsa.pub -rw-r--r-- 1 abc staff 391B Jun 28 19:59 known_hosts ➜ .ssh ssh localhost Password: –  ujava Jun 28 at 17:14
    
Is public key authentication enabled in your sshd_conf? Check for 'PubkeyAuthentication yes'. Bay the way this is not an answer. –  deagh Jun 28 at 17:41
    
The method to add more information in a question is by editing the question not by posting an answer. Please take a look at the tour –  HBruijn Jun 28 at 17:47
    
I changed "PubkeyAuthentication yes" ➜ sudo vim /etc/sshd_config ➜ .ssh ssh localhost Password: –  ujava Jun 28 at 17:48
    
And ensure that authorized_keys can only be accessed by the owner, i.e. chmod 0600 ~/.ssh/authorized_keys –  HBruijn Jun 28 at 17:51

Not the answer you're looking for? Browse other questions tagged or ask your own question.