Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

For months we are having problems with a Debian now 7.5 with samba 4.0.0beta2 that works as an AD DC. And now I am responsible to migrate it to a new machine. For what I see I don't need to export/use everything from this server (correct if I am wrong), need only to export users, shares, permissions and mainly the server SID (so we won't need to rejoin each machine to the AD DC).

As the server has some little crashes from time to time, it seams to affect (or not) some commands that I need to get/export the configs. For example, if I try to run net getlocalsid or net getdomainsid. net rpc getsid works and gives me the SID but I cannot get all to compare. The following occurs when I run both net getdomainsid or net getlocalsid

Ignoring unknown parameter "server role" Ignoring unknown parameter "server services" Ignoring unknown parameter "dcerpc endpoint servers" Ignoring unknown parameter "allow dns updates" Ignoring unknown parameter "dns forwarder" Ignoring unknown parameter "dns recursive queries" No builtin nor plugin backend for samba4 found PANIC (pid 9723): pdb_get_methods_reload: failed to get pdb methods for backend samba4

BACKTRACE: 8 stack frames: #0 net(log_stack_trace+0x1a) [0x7f93d56f528a] #1 net(smb_panic+0x22) [0x7f93d56f5362] #2 net(+0x2e12d6) [0x7f93d56992d6] #3 net(initialize_password_db+0x14) [0x7f93d569bee4] #4 net(+0x102ba8) [0x7f93d54baba8] #5 net(main+0x8f6) [0x7f93d54b9fa6] #6 /lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xfd) [0x7f93d2585ead] #7 net(+0x1021a5) [0x7f93d54ba1a5] Can not dump core: corepath not set up

I also seams to interfere with samba_backup, script that comes with samba 4.x source.

apt-get upgrade, apt-get dist-upgrade, apt-get -t wheezy-backports upgrade, apt-get -t wheezy-backports dist-upgrade break more the system on different ways.

Some advice how to proceed?

share|improve this question
    
You're running your production network off a beta version of Samba? Even if Samba were the standard tool for running AD, that seems like a poor choice. –  devicenull Jun 30 at 1:25
    
Yes! I am just inheriting it. –  tenshimsm Jun 30 at 12:54
    
These problems were solved when I manage to upgrade to samba4.1.11 via backports. And ran the recommended commands before put it online. Inside the release 4.0.0 in section Upgrading they have some orientation. samba.org/samba/history/samba-4.0.0.html And in the wiki. wiki.samba.org/index.php/Updating_Samba It's for upgrading from ver. 3 to 4 and for erlier versions o 4, alphas, betas ... –  tenshimsm Sep 28 at 16:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.