Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to setup a Cisco 5510 to route traffic between the outside and inside interfaces where both belong to public IP subnets. Our ISP assigned us a single point-to-point IP (207.107.110.150/30) which I've assigned to the outside and a /29 (207.107.101.112/29) which I've assigned 207.107.101.113 to the inside interface.

With identity NAT setup, from a host in the /29, I can ping the ASA, and I can ping the next hop in the route (207.107.110.149), however traffic sent to the global internet doesn't make it back to the inside interface.

Based on the message "6 Jul 01 2014 20:53:42 302015 8.8.4.4 207.107.101.115 Built outbound UDP connection 7052 for Outside:8.8.4.4/53 (8.8.4.4/53) to inside:207.107.101.115/57511 (207.107.101.115/57511)" it looks like traffic is arriving at the ASA so it's the ASA that's dropping them.

The ASA's "Packet Tracer" shows these should exit the inside interface.

Slightly obfusticated config:

asdm image disk0:/asdm521.bin
no asdm history enable
: Saved
:
ASA Version 7.2(1) 
!
hostname *****
domain-name *****
enable password ***** encrypted
names
!
interface Ethernet0/0
 nameif Outside
 security-level 0
 ip address 207.107.110.150 255.255.255.252 
!
interface Ethernet0/1
 nameif inside
 security-level 50
 ip address 207.107.101.113 255.255.255.248 
!
interface Ethernet0/2
 shutdown
 no nameif
 no security-level
 no ip address
!
interface Management0/0
 nameif management
 security-level 100
 ip address 172.24.19.1 255.255.255.0 
 management-only
!
passwd ***** encrypted
ftp mode passive
dns server-group DefaultDNS
 domain-name rsius.com
access-list Outside_access_in extended permit ip any 207.107.101.112 255.255.255.248 
pager lines 24
logging enable
logging asdm informational
mtu management 1500
mtu inside 1500
mtu Outside 1500
asdm image disk0:/asdm521.bin
no asdm history enable
arp timeout 14400
nat (inside) 0 207.107.101.112 255.255.255.248
access-group Outside_access_in in interface Outside
route Outside 0.0.0.0 0.0.0.0 207.107.110.149 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
http server enable
http 0.0.0.0 0.0.0.0 inside
http 172.24.19.0 255.255.255.0 management
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd address 172.24.19.2-172.24.19.254 management
dhcpd enable management
!
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map 
  inspect ftp 
  inspect h323 h225 
  inspect h323 ras 
  inspect rsh 
  inspect rtsp 
  inspect esmtp 
  inspect sqlnet 
  inspect skinny 
  inspect sunrpc 
  inspect xdmcp 
  inspect sip 
  inspect netbios 
  inspect tftp 
!
service-policy global_policy global
prompt hostname context 
: end

What needs to change to get traffic routed from the inside to the outside and back?

share|improve this question

1 Answer 1

up vote 0 down vote accepted

Since you are not natting on your Inside interface:

nat (inside) 0 207.107.101.112 255.255.255.248

Your provider needs to know that the subnet 207.107.101.112/29 is routed through 207.107.110.150. They will in turn broadcast the route for the rest of us to reach your Inside interface through the Outside interface of your ASA.

Did you check with them to make sure the subnet is routed accordingly?

share|improve this answer
    
You're correct, our ISP had broken the route somewhere deep in their network. It had nothing at all to do with the ASA. –  kbralten Jul 8 at 17:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.