Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Kind of related to this question here - has anyone here succesfully deployed exchange (2007) clients on the Mac? And I don't just mean access to the mailbox, but the whole kit - calendars, invitations, tasks, etc.

Not being familiar with administering Macs we have a new employee who is BYO'ing his Macbook and due to politics there's nothing I can do except suck it up and deal with it, and I just know that if he's not on the exchange for real it's going to cause problems when he misses meeting invitations and doesn't complete tasks because he doesn't have access to that functionality (and we all know who will get blamed).

share|improve this question
add comment

7 Answers

up vote 5 down vote accepted

Two options...

  1. Microsoft Entourage which comes part of Office 2008 for Mac

  2. OS X 10.6 (aka Snow Leopard) and Apple Mail/iCal

I use Entourage. Haven't tried the Exchange support in OS X 10.6 yet.

share|improve this answer
    
I read that Entourage does not have native Exchange support, and that it was never intended to be a replacement for Outlook. But I will look into 10.6, because that's a fairly cheap option if it's native! –  Mark Henderson Sep 1 '09 at 1:45
    
Entourage is horrific. Don't even bother to try and use it for anything halfway useful. –  rodjek Sep 1 '09 at 4:10
    
It does the job for me. Our company insists on an Exchange server and I insist on using a Mac so I have to make do. –  EmmEff Sep 1 '09 at 18:12
    
I'm not sure what is meant by "does not have native Exchange support", but I get my Exchange appointments and email from Entourage. Is there something I'm missing? –  EmmEff Sep 1 '09 at 18:13
add comment

Snow Leopard has native support for Exchange.

share|improve this answer
add comment

Going forward, Office 2010 for Mac will include Outlook, not Entourage. This will presumably have full support, just as Outlook for Windows does. Until that time, as others have said, 10.6 (Snow Leopard) will likely be your best choice. Especially considering the very modest price.

share|improve this answer
    
I expect this will need Exchange 2007 but I don't have a link to support that. But the WebServices is the new standard MS is using for 2007 and beyond –  SpaceManSpiff Sep 1 '09 at 12:44
    
The 10.6 support is designed for Exchange 2007, yes. Though, my understanding, is that there is still some support for 2003. Where does WebServices come into play, though? –  Scott Pack Sep 1 '09 at 13:14
add comment

The Snow Leopard support is pretty good. It doesn't support delegation, access to other mailboxes, etc. But it's great for everything else, and I have an assistant for the rest :)

Entourage sucks in many ways; don't subject your users to it.

share|improve this answer
    
Bugger, delegation is something we use regularly. Still, if Office 2010 comes with outlook, won't be an issue for too long, and I'm sure they can live without it for the moment. –  Mark Henderson Sep 1 '09 at 2:12
    
You CAN access other users mailboxes with IMAP, if that is enabled. It won't address shared calendars, etc, but will allow you access a group mailbox, etc. –  duffbeer703 Sep 1 '09 at 3:33
add comment

If you have Exchange 2007, you can use MacOS X 10.6 (Snow Leopard) for most of the features that you have in Entourage.

If you are on Exchange 2003 then you have to use Entourage to get the full experience.

You can always just use IMAP and stick to just email, but that's not that good of an idea.

Also, you will want to make sure you have a proper SSL cert so you don't get SSL cert validty errors on the Mac client (ie: don't use the default SSL cert...), etc.

share|improve this answer
add comment

If you're using Entourage for mac I would HEAVILY recommend the newly released update for Entourage - web services edition. You'll find it here: http://www.microsoft.com/mac/itpros/entourage-ews.mspx

This update uses Exchange Web Services to talk to you Exchange servers, instead of the old (and horrific) webdav way of doing this. Webdav required some tweaking on your servers, which could be bothersome. The EWS update installes on top of your Entourage installation and makes everything a blast. The updated Exchange support in snow leopard also uses EWS. Use one of the two. It will make your life easier.

share|improve this answer
    
+1 cause you actually put a supporting link in it –  SpaceManSpiff Sep 1 '09 at 12:42
add comment

As other people have answered, Snow Leopard has support for Exchange 2007.

However, be aware that the minimum version of Exchange Server 2007 supported is Service Pack 1 Update Rollup 4, which was released in July 2008. (From http://www.apple.com/macosx/specs.html).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.