Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

OS: Ubuntu 14.04 LTS

Software Raid 10: 4x120Gb Intel 530 SSDs

Initial tests:

1.2 GB/s Write
5.2 GB/s Read

I did some tests to check if everything will go alright with a failed disk:

  • I set as failed and removed /dev/sda partitions (2).
  • Rebooted (boots alright)
  • Added the two partitions back to the arrays. Rebuilding the arrays.

After rebuild:

220 MB/s Write
5.2 GB/s Read

Speed tests were made with dd (2GB file)

Is there something I miss? It looks to me like some setting problem.


cat /proc/mdstat
Personalities : [linear] [multipath] [raid0] [raid1] [raid10] [raid6] [raid5] [raid4]
md1 : active raid10 sda2[4] sdd2[5] sdc2[2] sdb2[1]
      39095296 blocks super 1.2 512K chunks 2 near-copies [4/4] [UUUU]

md0 : active raid10 sda1[4] sdc1[2] sdd1[3] sdb1[1]
      195177472 blocks super 1.2 512K chunks 2 near-copies [4/4] [UUUU]

unused devices: <none>
share|improve this question
    
Is the rebuild complete? –  Chopper3 Jul 4 at 15:17
    
Everytime I check it after it's complete. It takes only 10-12 minutes. –  deadtired Jul 4 at 15:18
    
The only related information I found is connected to /etc/fstab with setting the wrong options. But I tried them all and it's not from there. –  deadtired Jul 4 at 15:59
    
I cannot believe what was going on: overwrite. Because every second test was using the same target file, it seems that it didn't behave like writing a fresh new file at maximum speed... –  deadtired Jul 30 at 6:29

1 Answer 1

Did you repeat this, perhaps multiple times?

Since read performance is not impacted at all, I'd suspect slow write performance of the "failed" SSD due to insufficient free (trimmed) FLASH blocks. Every RAID-rebuild does a full write to the newly added device, thus writing large amounts of data and depleting the target device of pre-erased blocks.

From linux 3.7 on, linux software RAID should support ATA TRIM; maybe you could give it a try: "force-trim" with "sudo fstrim ". I'd be interested in whether write performance will be back to normal after a long enough time for the SSD firmware to erwas trimmed blocks.

share|improve this answer
    
I repeated the test more than 30 times in the last few hours. I run 'fstrim /' and after that the speed stays at 200 MB/s. –  deadtired Jul 4 at 16:08
    
I'm not sure whether the SSD controller will erase the blocks immediately on trim. Maybe write speed will increase after some "settling time"? - Should this not be the case, I'm out of ideas, sorry. –  matt_gnu Jul 8 at 15:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.