Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to add a hook to svn so that you can edit messages on commits. But whatever I do I get the same error message.

Revprop change blocked by pre-revprop-change hook (exit code 255) with no output.

This is the hook i have not (It is the default one)

#!/bin/sh

REPOS="$1"
REV="$2"
USER="$3"
PROPNAME="$4"
ACTION="$5"

if [ "$ACTION" = "M" -a "$PROPNAME" = "svn:log" ]; then exit 0; fi

echo "Changing revision properties other than svn:log is prohibited" >&2
exit 1

But i have also tried without any result.

#!/bin/sh

exit 0

I have give the entire repository 777 file right to exclude that possibility, yet no result.

This is the command I use for testing.

svn propset -r 1 --revprop svn:log "new log message" [url]

(removed my url but something like is it svn://exampel.com/project)

What I'm i doing wrong?

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.