Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I installed by yum the latest rsh package ( because on my linux machine rsh and rcp binaries not exists )

 # yum install rsh

so I verified by:

rpm -qa | grep -i rsh

 rsh-0.17-60.el6.x86_64
 rsh-server-0.17-17.x86_64

then I reboot my linux machine - red-hat 6.4

and try to do the following tests

# rsh localhost
  connect to address ::1: Connection refused
  Trying 127.0.0.1...

.

 rcp localhost:/etc/hosts /tmp
 rcmd: localhost: Connection reset by peer

in my machine .rhosts and /etc/hosts.equiv not exists ( not sure if rsh installation VIA yum should create them ? )

please advice what the next steps that I need to do in order to solve this issue ?

share|improve this question
    
Is there a good reason for using rsh (and not ssh)? –  Janne Pikkarainen Jul 8 '14 at 11:21
    
I not have ssh server on remote machine -(: –  maihabunash Jul 8 '14 at 11:22

1 Answer 1

up vote 1 down vote accepted

To be honest, I've never used rsh (only SSH). I am under the impression the rsh server is not started / listening to connection properly.

  1. Is the server process running

ps aux | grep rsh

Note: "ps aux" will list all processes. You should have a line with "rsh".

  1. Is the process listening to TCP/514

ss -t -l

Note: Display all tcp socket which are listening. You should have one for port 514. I use "ss" which is the replacement of netstat. I am not sure if it is installed on your Red Hat.

Finally, here is a tutorial I found. It seems like you might need to edit the configuration file to enable the daemon.

http://www.itzgeek.com/how-tos/linux/centos-how-tos/setup-remote-shell-access-on-centos-6-rhel-6.html#axzz36sMYbceE

share|improve this answer
    
I get this from my machine --> ps aux | grep rsh root 2172 0.0 0.0 103236 860 pts/0 S+ 14:51 0:00 grep rsh –  maihabunash Jul 8 '14 at 11:51
    
btw - I was in burn before 10 years –  maihabunash Jul 8 '14 at 11:53
    
maihabunash: The output you have is the "grep" command running with the argument rsh. If you only have this line, when you don't have a process rsh started. Check the link I posted... it should be helpful. –  Alex Jul 8 '14 at 12:23
    
I do all the steps according to the link and still not have the proccess –  maihabunash Jul 8 '14 at 12:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.