Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am new to FreeBSD and I try to mount a partition p2 of ada1 on a new FreeBSD installation by entering:

sudo mkdir -p /mnt/ada1p2
sudo mount /dev/ada1p2 /mnt/ada1p2

This leaves me with mount: /dev/ada1p2 : Invalid argument and no mounted partition. The partition scheme is GPT and I am not sure about the file system but I should be HFS+ or ext4.

What did I do wrong?

share|improve this question
Is your partition really ada1p2? Isn't it actually ad1s2? What is listed in /dev? – Rob Jul 8 '14 at 12:07
Plain mount treat partition as UFS2. If you have different FS on the partition, you should use -t <fstype> with mount – Kondybas Jul 8 '14 at 12:14
@Rob: Yes, it seems to be ada1p2. I checked /dev. – Ramon Jul 8 '14 at 12:34
@Kondybas: Using hfs and ext4 as fstype leads to the message mount: /dev/ada1p2: Operation not supported by device. I guess I have to install support for those file systems but I could not find out how. ls /sbin/mount_* doesn’t reveal hfs nor ext4. – Ramon Jul 8 '14 at 12:35
AFAIK FreeBSD hasn't native support for ext4 yet. HFS/HFS+ can be mounted when kernel built with GEOM_APPLE option. – Kondybas Jul 8 '14 at 12:49

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.