Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I usually connect to a remote server over Remote Desktop Connection, however this time it doesn't work (for this particular new server) and I don't really know what to blame.

I connect to the network using VPN an that works fine, however when I want to use Remote Connection to connect to the server it won't work ... I think the problem might be that the remote server has the same ip in its domain that a server has in our domain.

I'm not sure how to check what is really the problem. If I try to ping after connecting the VPN, I think I'm still getting the response from our server, not from the remote one.

Is there a way to specify domain name when trying to ping?

Either way I'm not sure why I can not connect to the server. The bottom line is that the VPN connects just fine and remote connection won't work. What is usually at fault?

P.S.: I don't have the control over any of the two Domains or IPs.

EDIT: This just became weirder ... I just tried RDPing to the remote server in question and got the following error message:

The connection was denied because the user account is not authorised for remote login.

Then I tried entering the wrong password on purpose and it tells me the password is wrong. Now this leads me to believe that the Remote Desktop Connection works correctly and the IT company on the other side just screwed up my user rights ... Is that possible? Would that explain what is going on?

share|improve this question

2 Answers 2

Hmmm - If your local network and the remote network have the exact same IP range and subnet mask, then pinging/connecting by IP to a particular system will likely depend on your adapter order (the order in which your OS looks at your network connections). For example, say you have your LAN connection and a VPN connection as your network adapter choices. If your VPN connection adapter is first in the order, when you try to connect to a remote machine by IP, it will connect using the VPN connection and hit the local system. If your LAN adapter is first, however, it will try locally first and connect to the local system.

To get around this situation, use the FQDN of the remote server - servername.domain.com - to ping and connect. When you connect to the VPN you will likely obtain IP address, subnet mask, gateway, and (hopefully) DNS server values and a connection-specific DNS suffix for the other domain. By specifying the FQDN of the server, you are telling it to use the VPN adapter based on the domain instead of relying on the adapter order to determine which network you connect to.

share|improve this answer
    
thank you, this way I did get a response with a larger ping value - leading me to believe that now I am pinging the remote server. However remote connection won't connect this way either with servername.domain.com or with the ip that the ping prints. –  Rekreativc Sep 1 '09 at 12:20
    
can you connect to anything in the other domain over VPN? maybe RDP is not permitted over the VPN for whatever reason. Another test - disconnect from the VPN and RDP to the local server with the same IP. If you connect and get a login window, then it is trying to get to the remote server while on VPN and failing. You can also try connecting via UNC (\\servername\share) and poke around to determine which server you are connecting to. –  August Sep 1 '09 at 13:12
    
I'm very suprised that this worked. –  pjc50 Oct 7 '09 at 9:26
    
Why? If you think about it, yes the local LAN and the remote LAN have the same IP range, but you are connecting to them via 2 separate network adapters - your physical NIC and the VPN virtual NIC. Therefore, NIC adapter order would determine which network (local or VPN) you look at first. To test this theory (and it IS just a theory since I have never done it), you could use 2 physical NICs in a PC and dual-home to 2 separate networks with the same IP ranges - your adapter order will determine which network you try to get to first. –  August Oct 7 '09 at 16:27

If the local and remote networks are sharing an IP range, it seems extremely counterintuitive to me that you could get this to work at all. Why would a packet destined for your local subnet ever travel to your gateway? It shouldn't, by definition.

However, I'm looking forward to learning exciting new tricks if someone knows how to make this work. Otherwise I'd think you're going to be stuck trying to go through LogMeIn or some similar remote control app rather than VPN.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.