Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I've got the following bind9 configuration and seem not to be able to find the source of's problem on that:

@ IN SOA (
        2014070809 ; serial
        8H ; refresh
        2H ; retry
        1W ; expiry
        11h) ; minimum
@    IN    NS
@    IN    NS
@    IN    MX    10
mail    IN      A     
mail    IN      AAAA            2001:41d0:8:6587:20::
imap    IN      A     
imap    IN      AAAA            2001:41d0:8:6587:20::
smtp    IN      A     
smtp    IN      AAAA            2001:41d0:8:6587:20::
pop3    IN      A     
pop3    IN      AAAA            2001:41d0:8:6587:20::
@       IN      A     
@       IN      AAAA            2001:41d0:8:6587:20::
www     IN      A     
www     IN      AAAA            2001:41d0:8:6587:20::

DENIC's nameserver check returns the following errors:

106  Received response does not provide expected records directly (resolver, NS, RR)
DEFAULT resolver

106  Received response does not provide expected records directly (resolver, NS, RR)
DEFAULT resolver

The corresponding section (according to error code documentation) "2.1.3 paragraph 3" semms not to even exist.

Any help on finding the problem here would be appreciated ;)

share|improve this question

1 Answer 1

up vote 3 down vote accepted

You specify as a nameserver, but there is no A or AAAA record for


ns    IN      A     

Hint: whenever you change your zone, first run named-checkzone on it.
It will tell you such problems.

share|improve this answer
Is this even required if the nameserver is not in the same zone as the domain itself? – Hikaru-Shindo Jul 9 '14 at 8:20
No. Well I'm unsure what you mean. They need an A in their zone of course, but not yours. – faker Jul 9 '14 at 8:23
In their own zone they seem to be CNAMEs ;) But named-checkzone just complains that the MX is a CNAME ... You may try it "". I forgot to mention the domain in the question – Hikaru-Shindo Jul 9 '14 at 8:25
Thanks. I changed from CNAME to A/AAAA and now it works. I knid of dislike this redudancy (since it's identical to the zone's root), but now it works. – Hikaru-Shindo Jul 9 '14 at 8:27
Right, NS cannot point to a CNAME – faker Jul 9 '14 at 8:32

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.