Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have searched around and havent really found an answer anywhere and this is still not working for me. I am using compression in IIS7 and it doesn't appear to be working. The code I am using is per

<urlCompression
      doStaticCompression="true" />
    <httpCompression 
      cacheControlHeader="max-age=86400"
      sendCacheHeaders="true"
      expiresHeader="true"
      minFileSizeForComp="0"
      directory="%SystemDrive%\inetpub\temp\IIS Temporary Compressed Files">
      <scheme name="gzip" dll="%Windir%\system32\inetsrv\gzip.dll" />
      <staticTypes>
        <add mimeType="text/*" enabled="true" />
        <add mimeType="message/*" enabled="true" />
        <add mimeType="application/javascript" enabled="true" />
        <add mimeType="*/*" enabled="false" />
      </staticTypes>
    </httpCompression>

However my content is still not being gzipped ? Any ideas why this is happening ?

Cheers

share|improve this question
    
anyone can help ? –  Thomas Sep 1 '09 at 15:01
2  
You need to be a little more patient. You can't expect your every query to be responded to in 25 minutes or less... It would also help if you provide more detail. What content is not being compressed? How are you testing the compression result (i.e. which client programs and/or services)? –  David Spillett Sep 1 '09 at 15:08
    
Question appears on StackOverflow a lot: stackoverflow.com/questions/4091536/… and stackoverflow.com/questions/2644465/… and –  David d C e Freitas Apr 29 '11 at 14:47
add comment

2 Answers

What content are you expecting to be compressed? Plain HTML files, script output, CSS, JS, ...? The section of configuration above is only for static compression so will not be affecting dynamic content such as the output from ASP.NET or "classic ASP" scripts - there are separate options for dynamic content.

Also: ensure that the directory listed for storing the compressed static files exists and does not have permissions that would stop IIS writing to it.

share|improve this answer
    
hey thx for the response. mainly just CSS & JS? I am testing the compression result in FF using Google PageSpeed / YSlow - both return that the compression isnt enabled ? –  Thomas Sep 1 '09 at 15:12
add comment

Are you behind a proxy? I've seen HTTP proxies sending uncompressed responses to the clients.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.