Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

We have an OWA server that we need to setup on Exchange 2007 SP1 on Server 2008. OWA is enabled under client access. I am able to get to the OWA web site, login, and authenticate. However, all of the graphics are broken ([X] = broken image):

Connected to Microsoft Exchange [X] M Find Someone [X] [X] Options ...

NOTE: can't use image tags as a new user

I'm pretty sure this is the result of a bad root pointer somewhere, but I can't seem to find the location. Since this affects all relative paths, the site doesn't "work" either, likely due to scripts with bad pointers.

I can't get the graphics themselves to display either. Trying: https://mail.mydomain.com/owa/8.1.375.2/themes/base/logob.gif

does not display an image, despite looking "correct" based on the directory structure in:

C:\Program Files\Microsoft\Exchange Server\ClientAccess\owa\

Any ideas? Exchange is otherwise *knock* working fine. Thanks!

share|improve this question

6 Answers 6

up vote 4 down vote accepted

Hi it is easier to execute the following procedure.

FIX: Step 1) Load the Exchange Management Shell

Step 2) Navigate to your Exchange Bin directory via the management shell - usually C:\Program Files\Microsoft\Exchange Server\Bin

Step 3) Run the UpdateOWA.ps1 script (done by entering .\UpdateOWA.ps1)

share|improve this answer
This also fixed my permission settings. All images were also redirected to the forms login –  Sander Rijken May 28 '11 at 10:43
This fixed my missing images issue. –  notandy Mar 5 '13 at 14:22

The latest rollout appears to be missing both gifs and scripts, but OWA always referred to the folder corresponding to the latest rollup, rather than the folder 'current'. My solution was to copy the contents of E:\Program Files\Microsoft\Exchange Server\ClientAccess\Owa\ to E:\Program Files\Microsoft\Exchange Server\ClientAccess\Owa\8.1.393.1. This is assuming that your previous working version was and the current one is 8.1.393 (SP1 rollup 9). A handful of the files already existed in destination folders, which I opted not to overwrite. NB! make sure you make a backup copies of the folders.

share|improve this answer

The issue has been resolved, OWA is up & running. It involved having to un-and-re-install IIS 7 (which is just awful, BTW), un-and-re-installing Client Access components, and deleting & re-creating all virtual directories.

Thanks to all for your info & suggestions.

share|improve this answer
Dang, I'd just found a link mentioning OWA images not showing up being a result of IIS metabase corruption. There was a tool in the IIS6 resource kit for clearing that out, but nothing that I can find for 7 so far. Anyway, for your amusement searchexchange.techtarget.com/generic/… –  Kara Marfia Sep 24 '09 at 10:57

This work to me.

Open IIS, go to default web site, search and select owa content. Locate the current version and go to properties and select directory security. Probabily in the Authentication and access control the security is wrong, set this to Enable anonymous access and dismark any other security box.

This error ocurred when I applied update Rollup 12 sp3.

share|improve this answer

If you get a network capture, do you see 404s being sent or what? What kind of firewall/load balancing devices are in front of tis CAS server?

Tried re-applying the service pack?


Brian Desmond

Active Directory MVP

share|improve this answer
I get 200s on every request -- including graphics & scripts. IIS thinks they're being served up correctly. But I can't access them directly, which is perplexing. The files really are "there" in the directory structure... –  Sean O Sep 8 '09 at 14:51
I'm at SP1, Update Rollup 9. Perhaps SP2 will cure it? Monitoring feedback as it's relatively new. –  Sean O Sep 8 '09 at 14:53

Does this link help?

share|improve this answer
That's exactly what I'm experiencing. But the authentication change doesn't affect the display of graphics or (non-)loading of scripts. Thanks for the pointer, tho. –  Sean O Sep 8 '09 at 14:48

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.