Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've just taken over managing the network for a small charity, and am finding internet access very flaky - we keep getting "The connection to the server was reset while the page was loading." errors (HTTP Error 12031 according to the Windows network diagnostic tool).

It doesn't seem to be anything to do with our ISP since it also affects internal traffic (even requests to an Apache instance on my localhost!)

Adjusting the MTU setting in the Windows XP registry sometimes seems to help for a few minutes after rebooting, but the problem always returns.

share|improve this question
In the end it was our connection with our ISP that was at fault - the phone line was knackered. The error from the local Apache instance was coincidentally the same. – andygeers Jun 18 '10 at 12:53

MLAB's internet connection testing tools may help you out here.

Also, I have had certain webfilters cause messages like the one you listed. We used to use Cybersitter, but switched because of a similar problem.

Obviously, it would be easier to pinpoint if the issue occurred consistently with the same pages. You could try surfing to known-blacklisted pages or pages that you would assume are commonly filtered.

share|improve this answer

Check that your MTU is low enough. With some routers fragmentation is disabled and it would cause the exact issue that you are having. It has mostly been sorted out with modern routers working with the default 1500 but previously you needed to set it to around 1490. (this needs to be done on each machine behind it)

share|improve this answer
This was exactly the issue - very easy fix in the end! Thanks a lot! – andygeers Sep 2 '09 at 9:24
Hmm - actually, although this fixes it for a few minutes after reboot, the problem always seems to return, and sometimes the required MTU seems to drop by 28 bytes each time I adjust it. – andygeers Sep 8 '09 at 11:35
The default MTU for Windows is supposed to be 1500, but when I run the "ping" command shown on the website you linked to, the highest I can set it to is "1472". If I set it any higher, I get a "Packet needs to be fragmented..." error. Do you know why this is? Thanks. – Michael Jan 23 '13 at 19:30

Install Firefox with Firebug and take a look at the net transfers. Sometimes a part of a webpage is taking too long and the connection is being reset leaving the webbrowser behind with half a page, so it won't try to show you the site.

share|improve this answer
up vote 1 down vote accepted

The error message is what gets displayed whenever the connection is lost between your computer and the server before the page has finished loading. In the case of a local server, this might be because the server crashes during page generation (malconfigured server software? incompatible PHP/Apache modules?) or if it's with external sites then it might be because there is a problem with your internet connection.

If you have a dedicated phoneline for your net connection, try plugging an ordinary telephone in and check that you get a consist dialtone and that you can make calls to people. In our case, the dialtone was incredibly faint and people received an engaged tone when they tried to call in - that was the clue that the phoneline was knackered and we needed to call in an engineer to fix it.

share|improve this answer
For me, it was a faulty PHP extension. If you're experiencing this kind of error, comment out the new extension(s), restart Apache, and pray... – hohner Jun 14 '12 at 21:14

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.