Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

RHEL 6.5 + JBoss EAP 6.

I installed JBoss EAP 6 from the RHEL repos using grouinstall:

# yum groupinstall "JBoss EAP 6"

This seems to have worked fine except that the files for mod_cluster are not actually installed, even though yum say mod_cluster is installed. I've tried reinstalling the entire group, reinstalling just mod_cluster, clearing yum caches etc. Still digging but so far I am at a loss and RHEL support hasn't been helpful as yet.

RESOLVED: I believe this is a fault on Red Hat's end. They appear to have two packages named "mod_cluster", one which is part of Apache and one that is part of JBoss (which is just an alias for mod_cluster-native?):

mod_cluster.noarch : JBoss mod_cluster for Apache httpd
mod_cluster-demo.noarch : Sample app for mod_cluster
mod_cluster-native.x86_64 : JBoss mod_cluster for Apache httpd
mod_cluster.x86_64 : Apache HTTP load balancer

"yum groupinstall 'JBoss EAP 6'" is supposed to installed mod_cluster.noarch, not mod_cluster.x86_64.

'rpm -ql' results from this broken system, and the same from a system that works:

# rpm -ql mod_cluster

# rpm -ql mod_cluster
share|improve this question
How did you determine that the files are missing? Compared present files with the list of files that are in the rpm file? If not, please do so. – Sven Jul 11 '14 at 14:59
What does rpm -V mod_cluster say? – John Jul 11 '14 at 15:01
@SvW: Symlinks under $JBOSSHOME are supposed to point to the files under /usr/share/java. The files are not there. I compared with another server I built just prior and the files are there. E.g.,: /usr/share/jbossas/modules/system/layers/base/org/jboss/as/modcluster/main/mod_c‌​luster-container-catalina.jar -> /usr/share/java/mod_cluster-container-catalina.jar but /usr/share/java/mod_cluster-container-catalina.jar does not exist. – Shep Jul 11 '14 at 15:05
@John: rpm -V mod_cluster returns nothing. – Shep Jul 11 '14 at 15:07
What does the output of rpm -ql mod_cluster say? Can you see those files in your system? Please don't post this as a comment but edit it into your question so it's readable. – Sven Jul 11 '14 at 15:11

1 Answer 1


Two RHEL 6.5 VMs were built to run JBoss EAP in Domain mode, one system as a domain controller / master and the other as slave. These systems are working fine.

A third VM was added to function as a second slave. The template used to install this system was different from that used for the first two. In particular, the template used for this system included the "epel" (Fedora) repo. The two other VMs do not have this repo.

In all cases JBoss was installed as follows:

# yum groupinstall "JBoss EAP 6"

This groupinstall will install the package "mod_cluster". The epel repo has a mod_cluster package (mod_cluster.x86_64) that conflicts with the mod_cluster package in the JBoss EAP repo (jb-eap-6-for-rhel-6-server-rpms - mod_cluster.noarch / mod_cluster-native.x86_64).

Removing the epel repo solves the issue. In my case, I had the third VM rebuilt to match the first two.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.