Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

(I asked this question on SuperUser 3 days ago and had no answer...)

I would like to access my freshly installed apache server (via ports) on my FreeBSD guestOS from Windows 7. So I set my virtual network on VMWare to bridged, I edited the hosts file on my Windows, I opened a browser on Windows and tried to reach (guest's address)... But still, I can't get to my index.html web page. Google says that it cannot connect to The only thing I can do to see my "It works!" page is

lynx localhost

on freeBSD.

I disabled my Windows firewall, I can ping my FreeBSD from my Windows, and my Windows from my FreeBSD.

What am I missing?


I have no proxy, and my httpd.conf file has been correctly edited. Here it is :

share|improve this question
What exactly do you mean by "can't get to my index.html". Does the browser time out? Do you have a proxy configured for the browser? FreeBSD's default configuration has no firewall, did you have one enabled that you disabled, what exactly do you mean by "disabled my firewalls" in relation to FreeBSD? How was Apache installed? Did you change it's configuration at all? – Chris S Jul 13 '14 at 2:55
Is my question clearer now? – Amina Jul 13 '14 at 3:19
Try run command lynx from freebsd. Did you see "It works" page? – masegaloeh Jul 13 '14 at 5:00
I get "unable to connect to remote host". – Amina Jul 13 '14 at 12:40
Sounds like something in httpd.conf is off. Can you scrub and dump it to something like ? – Chris S Jul 13 '14 at 14:29
up vote 0 down vote accepted

Is FreeBSD firewall allowing EXTERNAL connections on port 80? You have not specified that you've checked this in your question.

Also make sure you have bind your server not only to localhost:80, but to or *:80 in general as well

share|improve this answer
Thank u! Now it works! I didn't know that I had to add *:80, I thought using localhost only would do the thing... Thanks again :) – Amina Jul 13 '14 at 15:52

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.